Sophie 2.0 Reader (#2) - source code checkout (#38) - Message List

source code checkout


Recently, I came accross some info on the source code and I am interested in checking it out, however, using the tortise gui svn client, I am getting no response from the sophie2 repository. Tried also SlikSVN command line version.

Can anyone tell me how to check out the source ?

Tree View Flat View (newer first) Flat View (older first)
  • Message #161

    Yep, I installed Eclipse 3.6 Helios, updated to the M2 eclipse thing, then clicked right and chose "import", then Maven something existing project, and things began to bump and grind a little, sputter, received msg "updating dependencies", then burped with a , hicc-up! Msg received ~ "" "an error has been enountered during your import Patrick", no kidding, it knew my name ? So I looked at the ide with amazement to see several individual projects with some warnings and some errors due to non-locatable things. The main sophie project did not have any errors at all and all the individual modules are listed under that. I corrected some things but I am still interested in how to get the entire system to bring itsself up without errors so I can click on it and watch things "run". I also right clicked on the main sophie project, and some of the individual projects listed above that and chose update dependencies maven, but it didn't seem to affect much. A while ago I was able to go from having approx 53000 errors or warnings down to 8000 or so, after what I did I don't remember. But it's back to the approx 50,000.

  • Message #160

    Probably would help if my Eclipse knowledge were expanded some more. Which it just did. And is.

  • Message #159

    No, it's not corrupted, the source download is ok. So I have some new things to try I am sure will lead me further. Has some success with the IDE of Eclipse.

  • Message #158

    Oh, ya know, it's starting to look like I corrupted the source download some how, I don't know how, but maybe I will try at it again.

  • Message #157

    Oh, well, the red "X's", some of them are for this "Description Resource Path Location Type AccessOptions cannot be resolved to a variable /org.sophie2.extra.comment/src/test/java/org/sophie2/extra/comment/persist line 73 Java Problem"

    Oh, wait a minute, I see the warning now, the red "!'s", here's one : "Description Resource Path Location Type Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment. Build path JRE System Library Problem " Installed in the workspace ? I have jdk 6 on my machine . Hmmmmm.

  • Message #156

    When I right click on a project node and select maven/update maven config,I get a "An internal error occurred during: "Updating Maven Configuration". java.lang.NullPointerException" error message. Update dependencies goes quick with no error msg though, but still the little red "X" is still beside the project icon. Oh, I just noticed that there is a small read "!" next to some project icons. Something to do with my misinterpretation of what all has to be done to bring it all up I am sure. : )

  • Message #155

    Yes, after trying unsucessfully to get the M2 maven integration to work in eclipse v3.4, I went back to the version 3.6 Helios of eclipse(reinstalled it) and reinstalled the M2 maven integration from I have the actual maven from installed and setup with environment vars and all. I setup eclipse to use the JDK not a JRE, I assume M2 would not even show up in eclipse if the JDK item were not being used. Although at one point I got a message about that from M2 requiring the JDK it couldn't find, however, I remedied that by changing a line in the eclipse.ini file. The message went away, strangely enough, when I removed the line from the .ini file just to see, I did not again receive the "message" from M2. So I assume that is ok. I import in eclipse as an existing Maven project, and there is an error msg at the end of the import. I removed the files in the plugins folder for the POM editor and the plugin for JDT as mentioned in the comments in PLATFORM_INFRASTRUCTURE_OVERVIEW. I performed the right click on some items in the project explorer then and selected Maven/update dependencies, to no avail. And that's it so far. I just don't know what's in a POM file. Of course I am missing a few external libraries, .jar files that are needed. Here's a run msg :"Error resolving version for plugin 'org.apache.maven.plugins:maven-compiler-plugin' from the repositories [local (C:\Users\admin1\.m2\repository), central (]: Plugin not found in any plugin repository -> [Help 1]"

    Also, I'm not sure if the very first time I tried importing that the eclipse version I was using may have done something to the trunk when I went to the next version of eclipse and used the same workspace and the whatever previous version of eclipse had done to the code base, so now I am trying to find what i did with the original source check out for starting from scratch. I may have the original SVN checkout without having to make a trip to another building where I can use the tortise s/w.

    I can import it all as a regular project and all the classes are seen by the workbench, no missing classes. Just won't then run for me. So, I'm gonna go back and try to reimport a, I think, accurate backup copy of the tortise svn checkout. Reinstall eclipse and M2 in the helios version of eclipse v3.6

  • Message #154

    Couple of questions. Do you have maven installed? You should have maven and the maven plugin installed. If so, have you run "Update dependencies"?

  • Message #153

    Well, I went back to the new version 3.6 eclipse and reinstalled the maven m2 plugin, the imported the sophie2 project and still, 52,000+ errors ? Don't know what else to try. Any hints ? If you have time for this. May restart with re-getting the SVN source again from the repository.

  • Message #152

    My knowledge of maven and eclipse is, to this point, limited. Just finished trying eclipse 3.4, however, the m2eclipse is not gonna install in v3.4 with the update site link that works for eclipse v3.6, however, it seems there is no maven plugin as good as M2 for eclipse v3.4, so I am going back to try it all over with v3.6 again and see what I may have done wrong last go around with v3.6. Maybe I'll go in and remove by hand the pom editor and the AJDT integeration modules and see what happens.

  • Message #151

    But I'm using Eclipse 3.6.1 with the newest maven plugin from sonatype. I am wondering since the sophie documentation mentions Eclipse 3.4, is that the version I need to use here ? I am going now to download the version 3.4 with the sonatype maven plugin for it.

  • Message #150


    Still working on a few minor details in bringing up the development environment. Then I will know if I am following the instructions closely enough, or if it's my lack of knowledge of the Eclipse IDE which is probably affecting my getting along.

  • Message #149

    Hi, do you mean you succeeded in building and running the project? If so, let me know in order to update/comment the wiki pages. If not, please give exact errors in order to be able to resolve them.

  • Message #148

    Note: Currently, one can merely look at my last message entered on here for the pertinent info, all previous messages are now obsolete ! Currently, I am looking at the below excerpt from the sophie docs :

    " make sure that Eclipse runs with JDK not JRE (see Window-Preferences-Java-Installed JREs, edit eclipse.ini with -vm <path to javaw executable file> or set correct PATH and JAVA_HOME variables) "

  • Message #147

    So, Basically, what I did was, checked out the trunk , installed eclipse, installed the M2 maven thing(incidentally, the installation GUI did not give me an option that I noticed for excluding AJDT integration or the POM editor as mentioned in sophie docs on here). Then I imported the eclipse project for sophie I previously got and tried to run the fakeauthor thing . Something is off, of course, all errors from now on. I imported the project as told how to in, with a few variations because of the eclipse version differences but basically the same. Must be missing something ? Any input ?

  • Message #146

    Yeah, still getting 53000 errors + : here is an excerpt (from an attempted run, also, still getting the import error messages Java null pointer exception) I followed the instructions that I read so far in the given sophie documents.

    Description Resource Path Location Type AbstractHalo cannot be resolved to a type / line 65 Java Problem

    Description Resource Path Location Type ACCELERATOR_PROP_ID cannot be resolved to a variable / line 29 Java Problem

    Description Resource Path Location Type AccessCreateCollectionUtil cannot be resolved /org.sophie2.base.model.text/src/main/java/org/sophie2/base/model/text/old line 52 Java Problem

    Description Resource Path Location Type AccessOptions cannot be resolved to a type / line 33 Java Problem

    Description Resource Path Location Type AccessOptions cannot be resolved to a variable /org.sophie2.extra.comment/src/test/java/org/sophie2/extra/comment line 114 Java Problem

  • Message #145

    I also found another document I am working on :

  • Message #144

    Oops... ! Pause, I was using the Eclipse Galileo installation I already had, now I have gone back and am reinstalling now with the newly downloaded Helios Eclipse intallation EE, and I already see the reference to Equinox in that update list. : )

  • Message #143

    Hi Again,

    I have successfully imported the SVN repository. Now, I installed

    the eclipse EE. I pointed to the M2 Maven plugin and installed that, however I was not given any options, to my knowledge that allowed deselecting the POM Editor or the AJDT integration as suggested in the Platform Infrastructure Overview web page. I am receiving several errors related to something called Equinox when I attempt to import the Sophie 2 software. Any suggestions ? Also, of course numberous java errors upon trying to run the below mentioned thing that is mentioned in the web page Platform deployment build in Eclipse :

    •Go to sophie2-platform/dev-tools. •To run Sophie2 Author right-click on author.FakeAuthorMain.launch and select Run as -> author.FakeAuthorMain

  • Message #142

    Oh, it's "" working now. I have moved to another building's wireless network, I believe it is less crowded. The website came right up. I have had this same issue on other things in the past.

  • Message #141

    Unless it's something to do with the wireless connection here : (here's what I get when I use the above zip file link) "Error: Forbidden Insufficient permissions to access /manage

    TracGuide — The Trac User..."

  • Message #140
  • Message #139

    Thank you,

    Don't see the linke for downloading in zip format etc. I have seen it elsewhere, but only when I drill down to individual files. I have downloaded a rather larger zip file of something else at another link that I don't know what it was, "qt-win-opensource-src-4.5.2.tar", doesn't look like anything other than some Unix thing. But I haven't seen any links that look like an archive zip of the Sophie2 . The svn url you gave me above is still taking a breather right now and won't respond when I cut and paste it into tortise svn gui.

  • Message #138

    Hi again, please retry with exact same address in tortoise svn. Alternatively you can donwload the source using trac Look below for the "Download in other formats: Zip Archive" option and use save target as.

  • Message #137

    Tried that URL you mentioned above , svn://, however, I received this message :

    Command: Export Error: Can't connect to host '': A connection attempt failed because the Error: connected party did not properly respond after a period of time, or established Error: connection failed because connected host has failed to respond. Finished!:

  • Message #136


    Thank you. Usually, it's instructive, to try and insert a foreign project into Netbeans and then chase down all the items that go awry. But, I'm away from that at this point. However, with the Eclipse project I am sure it would be possible to equate it to NB, if I wanted to.

  • Message #135


    You can read more about eclipse setup here DEVELOPMENT_OVERVIEW



    Consider checking out only trunk, svn:// since the separate branches are really huge.

    Non of the developers used netbeans, so I'm pretty sure it won't work...

  • Message #134

    Yes , the first time I tried the SVN url you gave me it did work. I ran out of time and had to shut down and come back to it and start over. Seems to be rather large, how large I don't have that information. I see it is set up for wha they call "Eclipse". I have eclipse for other things, but have not widely usd it much.

  • Message #133

    Would like to download it in its entirety and load in up into Netbeans an play around with it, compile it, etc. Are their quick and dirty intstructions somewhere on setting up the libs in Netbeans ? Nevermind the jDesktop imports I mentioned earlier.

  • Message #132


    Oh, the imports are in there, I tried that SVN url above. However, the same url doesn't seem to be working today, namely, svn://


  • Message #131

    Actually, this link seems to have the jdesktop imports involved :

  • Message #130


    You know, I am intereseted in a file for, which has the

    imports : Revision 4763, 36.5 KB (checked in by meddle, 16 months ago) #1802 GROUP_FILLING_R1 : Implementation (implemented by jani, reviewed by meddle)

    Line 1 package; 2 3 import org.apache.batik.ext.awt.MultipleGradientPaint; 4 import org.jdesktop.swingx.JXGradientChooser; 5 import org.jdesktop.swingx.JXMultiThumbSlider; 6 import org.jdesktop.swingx.color.GradientPreviewPanel; 7 import org.jdesktop.swingx.color.GradientTrackRenderer; 8 import org.jdesktop.swingx.multislider.Thumb; 9 import org.jdesktop.swingx.multislider.ThumbListener;

    The jdesktop code I am interested in perusing, however I noticed, and expected that the newer version didn't have the jdesktop imports. I am wondering what version has those in it ?

  • Message #129


    Just tried with Tortoise SVN and it works using this as adress: svn://

    Please let me know if that worked for you.



Tree View Flat View (newer first) Flat View (older first)


No attachments created.