Last modified 16 years ago
Last modified on 12/20/08 13:32:39
Avoid non desciptive names
A name should be clear enough to suggest what the thing is given the local context. For example: <pre> private static final int FRAME_CORRECTION_POSITION = 20; </pre> is not clear in the context of the class Frame. It may be more clear in the context of the frameDropped() method, but here it is not. A better name would be <pre> private static final int FRAME_DROP_OFFSET = 20; </pre>