Ticket #1668 (closed unplanned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago

GROUP_TIMELINES_R0

Reported by: sriggins Owned by: sveto
Priority: major Milestone: M06_ALPHA1
Component: TIMELINES Version: 2.0
Keywords: Cc: sveto
Category: EXTRA Effort: 0
Importance: Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: danvisel Design_owners: sveto
Imp._owners: sveto Test_owners:
Analysis_reviewers: Changelog:
Design_reviewers: meddle, pap Imp._reviewers: pap, kyli, meddle
Test_reviewers: Analysis_score: 5
Design_score: 3 Imp._score: 4
Test_score: 0

Change History

comment:1 Changed 14 years ago by kyli

  • Owner changed from sriggins to kyli
  • Status changed from new to s1a_analysis_started

comment:2 Changed 14 years ago by boyan

  • Status changed from s1a_analysis_started to s1b_analysis_finished
  • Analysis_owners set to kyli,boyan

finished the analysis started by kyli (45m)

comment:3 Changed 14 years ago by meddle

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to meddle
  • Analysis_score changed from 0 to 4

The analysis is complete and full, the link to the discussion log provides the answers to the "what" questions. 4p (40m).

comment:4 Changed 14 years ago by boyan

  • Design_owners set to boyan
  • Owner changed from kyli to boyan
  • Status changed from s1c_analysis_ok to s2a_design_started

starting design

comment:5 Changed 14 years ago by boyan

  • Status changed from s2a_design_started to s2b_design_finished

done in a total of almost 2d.

comment:6 Changed 14 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle

The design is OK. I have the following notes:

  • The UI unit test has some test methods that instead of source code have comments that act like a scenario for implementation. That thing is the one that decreased your design score.
  • There was a test method with assertEquals call that had it's expected and actual parameters misplaced.
  • Your last (collective) patch tells that th pom file of the new module is already created, but the module is new... so the patch is not completely right.

Aside of these thing, great design, I completely understood the idea of the new timelines.
3,5p (150m, worked with three different patches, and fought with applying them).

comment:7 Changed 14 years ago by boyan

  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to boyan

starting implementation

comment:8 Changed 14 years ago by boyan

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners changed from boyan to boyan,kyli

finished implementation

comment:9 Changed 14 years ago by meddle

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 0 to 2.5
  • Imp._reviewers set to meddle

The code is OK and the tests are good, but the timelines are with too many bugs:

  • The preview bugs are caused by the resource copying with templates.
  • There are bugs because of MyDoggy and the bottom flap
  • There are bugs running the timeline in author mode too...

2.5p (90m)

comment:10 Changed 14 years ago by boyan

  • Status changed from s2c_design_ok to s3a_implementation_started

starting reimplementation

comment:11 Changed 14 years ago by boyan

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners changed from boyan,kyli to boyan,kyli,boyan

reimplemented

comment:12 Changed 14 years ago by meddle

  • Status changed from s3b_implementation_finished to s2c_design_ok

I can not pass the implementation again, because there are some bugs that I can not merge to the trunk:

  • The BottomFlap AssertationError is present again, this time rarely, but is a fact.
  • When I try rewind I have exceptions from the Timers with description "Timer already cancelled.".
  • The timers cause problems with our Changes, maybe because of the asynchronous events?

But copying with timelines is working indeed.

2.5p (1h)

comment:13 Changed 13 years ago by meddle

  • Status changed from s2c_design_ok to new

Resetting the task - The New Beginning!

comment:14 Changed 13 years ago by danvisel

  • Design_owners boyan deleted
  • Status changed from new to s1a_analysis_started
  • Imp._owners boyan,kyli,boyan deleted
  • Analysis_reviewers meddle deleted
  • Imp._reviewers meddle deleted
  • Design_reviewers meddle deleted
  • Owner changed from boyan to danvisel
  • Analysis_owners changed from kyli,boyan to danvisel

taking over analysis of this (with sveto).

comment:15 Changed 13 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

We think this is ready to be reviewed, though things might still need to change?

comment:16 Changed 13 years ago by deyan

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_score changed from 4 to 5

Though UI may change, we should see how this will work. Assuming timeline page is part of this analysis.

comment:17 Changed 13 years ago by sveto

  • Cc sveto added
  • Design_owners set to sveto
  • Status changed from s1c_analysis_ok to s2a_design_started
  • Owner changed from danvisel to sveto

comment:18 Changed 13 years ago by sveto

  • Status changed from s2a_design_started to s2b_design_finished

(38.5h)

comment:19 Changed 13 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 3.5 to 3
  • Design_reviewers set to meddle, pap

I'll pass the design, but you should know that the new timelines must be persistable and must not broke anything!

  • If you rename something in your code rename it into your UML diagram too!
  • You MUST create a new private branch, sub-branch to your for that task and to put the code for the timelines (only it) there. At this moment your code will be hardly merge-able so the implementation will not pass.
  • Make the TimelineEntity immutable, not proobject.
  • Where can we read how the actual playing of timelines will be written? Because the design is the documentation it must contain this kind of information.

3p (40m)

comment:20 Changed 13 years ago by sveto

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:21 Changed 13 years ago by sveto

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:22 Changed 13 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._owners set to sveto
  • Imp._score changed from 2.5 to 4
  • Imp._reviewers set to pap, kyli, meddle

Tested hours and hours, works fine, code is fine.
Write your name as the implementation owner.

4p (4h)

comment:23 Changed 13 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.