Ticket #1713 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

Tweak: Shift in text

Reported by: deyan Owned by: nenko
Priority: critical Milestone: M09_BETA1
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: dan Design_owners: nenko
Imp._owners: nenko Test_owners:
Analysis_reviewers: deyan Changelog:
Design_reviewers: pap Imp._reviewers: pap
Test_reviewers: Analysis_score: 4
Design_score: 0 Imp._score: 4
Test_score: 0

Description

It would be great if we could use the SHIFT key when typing in text frames.

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1c_analysis_ok

comment:2 Changed 10 years ago by nenko

  • Design_owners set to Team 1

comment:3 Changed 10 years ago by nenko

  • Design_owners changed from Team 1 to nenko
  • Owner set to nenko
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:4 Changed 10 years ago by nenko

This bug is due to lack of interaction entry for listening to key entries when the Shift key is typed. This means that if we add a new interaction entry in the interaction map definition the bug will be solved. The interaction entry should state that when Shift key is pressed and key typed the same Event should be fired as the one when key is typed.
So in HotTextContentView#defineSkin(ElementSkinPart part) a new line will be added :

part.addInteraction("KEY_TYPED M_SHIFT", Ops.INSERT_CHAR);

comment:5 Changed 10 years ago by nenko

  • Status changed from s2a_design_started to s2b_design_finished

comment:6 Changed 10 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok

You can pass such bugs to automatically to implementation finished when you are ready with them, and their review can be done one time.

  1. The analysis of bugs is done when they are reported .
  2. A programmer picks such a bug that is an_fi and if he/she understands the report moves it to an_ok
  3. The programmer gives a solution plan and fixes the bug then changes it to im_fi
  4. Integrator reviews the bugfix and move them to im_ok with mark and then to fixed.
  5. If the bugfix fail the status will be returned to an_ok.

The problem is clear and I think the solution is ok...

comment:7 Changed 10 years ago by nenko

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:8 Changed 10 years ago by nenko

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners set to nenko

Implementation finished - 3739

comment:9 Changed 10 years ago by pap

  • Status changed from s3b_implementation_finished to closed
  • Design_reviewers set to pap
  • Resolution set to fixed
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to pap
  • Ok
  • Committed to trunk in [3759]
Note: See TracTickets for help on using tickets.