Ticket #1740 (closed bug: worksforme)

Opened 10 years ago

Last modified 10 years ago

crash when saving book with chained text frames

Reported by: danvisel Owned by: danvisel
Priority: critical Milestone: M09_BETA1
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: danvisel Design_owners:
Imp._owners: Test_owners:
Analysis_reviewers: meddle Changelog:
Design_reviewers: Imp._reviewers:
Test_reviewers: Analysis_score: 0
Design_score: 0 Imp._score: 0
Test_score: 0

Description (last modified by danvisel) (diff)

I made a book consisting of only Page 2 from here. When I'd finished the page, I saved the book; the attached crash happened. Saved book can be opened; text formatting is lost.

Attachments

chained text error.txt.zip (29.6 KB) - added by danvisel 10 years ago.
error on saving book with chained text frames.
demo page 2.sjrb (37.1 KB) - added by danvisel 10 years ago.
demo book page 2 - this crashed when saved.
chained text error.txt (1.2 MB) - added by danvisel 10 years ago.
error on saving book with chained text frames.

Change History

comment:1 Changed 10 years ago by danvisel

  • Owner set to danvisel
  • Status changed from new to s1a_analysis_started
  • Description modified (diff)

Changed 10 years ago by danvisel

error on saving book with chained text frames.

Changed 10 years ago by danvisel

demo book page 2 - this crashed when saved.

Changed 10 years ago by danvisel

error on saving book with chained text frames.

comment:2 Changed 10 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

(zip is the same error; I zipped it because the .txt is 1.2Mb and wasn't uploading.)

comment:3 Changed 10 years ago by meddle

  • Status changed from s1b_analysis_finished to closed
  • Resolution set to worksforme
  • Analysis_reviewers set to meddle

Hmmm tried to save such a book a few times, but everything was fine... May be the problem is not present anymore, reopen the bug if it continues to be present. By the way I don't know why but the attachments in the truck that are since more than 3 days are all lost...

Note: See TracTickets for help on using tickets.