Ticket #1827 (closed bug: fixed)

Opened 10 years ago

Last modified 9 years ago

crash: crash when pressing DELETE after typing in sticky

Reported by: danvisel Owned by: diana
Priority: major Milestone: M09_BETA1
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: danvisel Design_owners: diana, meddle
Imp._owners: diana, meddle Test_owners:
Analysis_reviewers: diana, meddle Changelog:
Design_reviewers: meddle Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3
Test_score: 0

Description

  1. Open Sophie.
  2. Create new book.
  3. Add new sticky.
  4. Type text in sticky.
  5. Press DELETE/BACKSPACE.

Crash on 5, attached.

Attachments

crash when pressing delete while entering text in a sticky (13.5 KB) - added by danvisel 10 years ago.
crash after pressing backspace while entering text in sticky

Change History

Changed 10 years ago by danvisel

crash after pressing backspace while entering text in sticky

comment:1 Changed 10 years ago by danvisel

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by diana

  • Design_owners set to diana
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to diana

The exception is caused by the fact that the source of the event when deleting in sticky isn't HotTextContentView but StickyView.
It is fixed by adding try/catch block and casting the source event to HotTextView.
source code: [4824]

comment:3 Changed 10 years ago by diana

  • Status changed from s2a_design_started to s2b_design_finished

comment:4 Changed 10 years ago by diana

  • Status changed from s2b_design_finished to s2c_design_ok

comment:5 Changed 10 years ago by diana

  • Owner set to diana
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:6 Changed 10 years ago by diana

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:7 Changed 10 years ago by meddle

  • Design_owners changed from diana to diana, meddle
  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._owners changed from diana to diana, meddle
  • Analysis_reviewers set to diana, meddle
  • Analysis_score changed from 0 to 3
  • Imp._reviewers set to meddle
  • Design_score changed from 0 to 3
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3

This fix is a classic Exception Swallowing case, so I fix it instead : [4910].

There are other sticky bugs:

  • In true runner stickies can not be inserted.
  • When type text in stickies and the bottom palette is opened the text is not showed...

3p (25m)

comment:8 Changed 10 years ago by deyan

  • Add Hours to Ticket set to 0
  • Estimated Number of Hours set to 0
  • Total Hours set to 0
  • Billable? set

blockes, stickys crash (windows)

comment:9 Changed 9 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

fixed

Note: See TracTickets for help on using tickets.