Ticket #1909 (closed bug: worksforme)

Opened 10 years ago

Last modified 10 years ago

Crash: Applying a template to it's parent causes "very dangerous" exception

Reported by: deyan Owned by:
Priority: major Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: jani
Imp._owners: jani Test_owners:
Analysis_reviewers: jani Changelog:
Design_reviewers: meddle, todor Imp._reviewers: meddle, todor
Test_reviewers: Analysis_score: 4
Design_score: 4 Imp._score: 4
Test_score: 0

Description (last modified by deyan) (diff)

Insert a text frame, add it as template and try to apply template to the frame. It happens with cycling dependencies too.

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by jani

  • Design_owners set to jani
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to jani

comment:3 Changed 10 years ago by jani

  • Status changed from s2a_design_started to s3b_implementation_finished

I added a isDerivedFrom method in FrameUtil which checks if the operation of applying a frame template does not create cyclic dependencies.

Changeset: [5232]

comment:4 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_reviewers set to jani
  • Analysis_score changed from 0 to 4
  • Imp._reviewers set to meddle, todor
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle, todor
  • Imp._score changed from 0 to 4

Merged into the release in [5240].

comment:5 Changed 10 years ago by milen

It works in the release on MAC.

comment:6 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to s1c_analysis_ok

Does not work in this release, exception is not the same.

comment:7 Changed 10 years ago by deyan

  • Description modified (diff)
  • Milestone set to M12_RELEASE

comment:8 Changed 10 years ago by boyan

  • Status changed from s1c_analysis_ok to closed
  • Resolution set to worksforme

I couldn't reproduce this and I believe it was fixed by Jani.

Note: See TracTickets for help on using tickets.