Ticket #1923 (closed unplanned_task: obsolete)

Opened 11 years ago

Last modified 10 years ago

GROUP_WRAPPERS_R0

Reported by: deyan Owned by: nenko
Priority: major Milestone: M11_BETA3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: nenko Design_owners: ivo, sveto, nenko
Imp._owners: ivo, sveto, nenko Test_owners:
Analysis_reviewers: dido Changelog:
Design_reviewers: pap Imp._reviewers: meddle, pap
Test_reviewers: Analysis_score: 4
Design_score: 3.5 Imp._score: 3
Test_score: 0

Change History

comment:1 Changed 11 years ago by deyan

  • Description modified (diff)

comment:2 Changed 11 years ago by nenko

  • Owner set to nenko
  • Status changed from new to s1a_analysis_started

comment:3 Changed 11 years ago by nenko

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:4 Changed 11 years ago by dido

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to dido
  • Analysis_score changed from 0 to 4
  • Please fill custom fields like Analysis_owners etc.
  • Everything else seems fine. Good luck.

Analysis Reviewed 4p (10m)

comment:5 Changed 11 years ago by nenko

  • Design_owners set to ivo, sveto, nenko
  • Status changed from s1c_analysis_ok to s2a_design_started
  • Analysis_owners set to nenko

comment:6 Changed 11 years ago by nenko

  • Status changed from s2a_design_started to s2b_design_finished

comment:7 Changed 11 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to pap
  • getInts returns a pointer. Isn't it better to use a buffer as an argument
  • There is a somewhat similar issue with methods that create Command and Response objects
  • Some memory leaks (mainLoop ifs with exit/throw)
  • The module is native but its root package is wrappers - this is strange
  • I think that it is better the C++ code to be in a subdir of the src/main src/test directories
  • The module should be something like core.native (core.wrappers)
  • Constructs like "catch( SomeException e){e.printStackTrace();} are totally unacceptable
  • The some refining should be done in a next revision and on implementation especially in order to make usage of this "library" easier to understand.

comment:8 Changed 11 years ago by nenko

  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to ivo, sveto, nenko

comment:9 Changed 11 years ago by nenko

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • getInts is changed to fill a buffer
  • The module is renamed to wrappers. I think that these wrappers are something completely new and should have a new category
  • There are issues (Eclipse or Java I don't know) a package name to contain the word "native"

comment:10 Changed 11 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 0 to 3
  • Imp._reviewers set to meddle, pap

Problems:

  • This exception is thrown after we receive the OK result in the demo.
    Exception in thread "Thread-0" java.lang.RuntimeException: java.io.EOFException
    	at org.sophie2.base.natlib.communication.bridges.NativeBridge.sendCommand(NativeBridge.java:186)
    	at org.sophie2.base.natlib.communication.bridges.NativeBridge.run(NativeBridge.java:143)
    	at java.lang.Thread.run(Thread.java:619)
    Caused by: java.io.EOFException
    	at java.io.DataInputStream.readInt(DataInputStream.java:375)
    	at org.sophie2.base.natlib.communication.bridges.NativeBridge.sendCommand(NativeBridge.java:184)
    	... 2 more
    
  • The main pom and the native module pom were not modified in your commits.
  • I don't like the name Response in your hierarchy (better is Result).
  • Umm the default path in the demo should be "native" + File.separator + "javaMessages.o", it was wrong...

So my conclusions : You didn't run it with true before giving it to review, you didn't run this demo :'(

3p (150m)

comment:11 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.