Ticket #1953 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

Unexpected behavior: Typing in zoom panel supports one character only

Reported by: deyan Owned by: nenko
Priority: major Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan, vanya Design_owners: nenko
Imp._owners: nenko Test_owners: vanya
Analysis_reviewers: vanya Changelog:
Design_reviewers: Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3
Design_score: 0 Imp._score: 3.5
Test_score: 3

Description (last modified by vanya) (diff)

When you try to type in 2 digit number, only first digit is accepted.

  1. Mark the digits in the zoom menu
  2. Try to write a double-digited number

The application writes down the first digit of the number you tried to write and puts the cursor at the end of the line.

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by pap

Actually it depends on your typing speed. But this is something annoying anyway.

comment:3 Changed 10 years ago by nenko

  • Design_owners set to nenko
  • Status changed from s1b_analysis_finished to s2a_design_started

comment:4 Changed 10 years ago by nenko

  • Status changed from s2a_design_started to s2b_design_finished

test and bug fixed - [6524]

comment:5 Changed 10 years ago by nenko

  • Status changed from s2b_design_finished to s2c_design_ok

The problem is that when typing a digit every value is submitted to the model (this is correct) but when the value is submitted the text field, where you type, loses the focus. This text field has s focus listener and when the focus is lost it updates its value with the one from the model - so if you type 23 (or at leat try to) the control submits 2, then updates its value with the one from the model, which is 2.00 and sets. If you want to continue typing (we want to type 23 remember?) you should click after '2' and type 3.

The fix if this bug is to delete syncInputFromModel on focusLost, this way you can type and the values are submitted but the value you type is not changed in real time. The drawback is this fix is that when you type 23 for example, the value in the text field will be 23 it will never become 23.00...

comment:6 Changed 10 years ago by nenko

  • Owner set to nenko
  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to nenko

comment:7 Changed 10 years ago by nenko

  • Status changed from s3a_implementation_started to s3b_implementation_finished

The changesets are:
[6524]

[6532]

comment:8 Changed 10 years ago by pap

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 0 to 3.5
  • Imp._reviewers set to meddle
  • Ok although this is rather a workaround but fixing would require refactoring of the so nice bound combo box

comment:9 Changed 10 years ago by vanya

  • Description modified (diff)

comment:10 Changed 10 years ago by vanya

  • Status changed from s3c_implementation_ok to new

comment:11 Changed 10 years ago by vanya

  • Status changed from new to s1b_analysis_finished
  • Analysis_owners changed from deyan to deyan, vanya
  • Analysis_score changed from 0 to 3

comment:12 Changed 10 years ago by vanya

  • Analysis_reviewers set to vanya

comment:13 Changed 10 years ago by vanya

  • Status changed from s1b_analysis_finished to closed
  • Test_owners set to vanya
  • Resolution set to fixed
  • Test_score changed from 0 to 3
Note: See TracTickets for help on using tickets.