Ticket #1965 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

"Frame hidden" does not work correctly

Reported by: deyan Owned by: kyli
Priority: major Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: kyli
Imp._owners: kyli Test_owners:
Analysis_reviewers: Changelog:
Design_reviewers: meddle, pap Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3
Test_score: 3

Description (last modified by deyan) (diff)

See attached book. When you click "Hide frame" on first row, the "Frame hidden" disappears, but it's target is not toggled ("Play me"). It is toggled if you click "Hide frame" again (and more times), but it should only if the first frame was visible, and then became invisible.

Attachments

linkbook8.sjrb (36.0 KB) - added by deyan 10 years ago.

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

Changed 10 years ago by deyan

comment:2 Changed 10 years ago by deyan

  • Description modified (diff)

comment:3 Changed 10 years ago by sveto

  • Design_owners set to sveto
  • Status changed from s1b_analysis_finished to s2a_design_started

comment:4 Changed 10 years ago by sveto

  • Design_owners sveto deleted
  • Status changed from s2a_design_started to s1c_analysis_ok

comment:5 Changed 10 years ago by kyli

  • Owner set to kyli
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:6 Changed 10 years ago by kyli

  • Status changed from s2a_design_started to s2b_design_finished

The problem is that FRAME_SHOWN and FRAME_HIDDEN events are fired every time a frame is visible / invisible. The solution is to put a bit more complicated logic in FrameView, more exactly in the visibilityEventSender prop. It must fire such event only if the visibility for the current time is different from the visibility during the last event firing.

comment:7 Changed 10 years ago by kyli

  • Status changed from s2b_design_finished to s2c_design_ok

comment:8 Changed 10 years ago by kyli

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:9 Changed 10 years ago by kyli

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Implementation finished in [6980].

comment:10 Changed 10 years ago by kyli

  • Status changed from s3b_implementation_finished to s3c_implementation_ok

comment:11 Changed 10 years ago by kyli

  • Design_owners set to kyli
  • Design_reviewers set to meddle, pap
  • Imp._owners set to kyli
  • Imp._reviewers set to meddle

comment:12 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

fixed

comment:13 Changed 10 years ago by deyan

  • Design_score changed from 0 to 3
  • Imp._score changed from 0 to 3
  • Test_score changed from 0 to 3
  • Analysis_score changed from 0 to 3
Note: See TracTickets for help on using tickets.