Ticket #2044 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

[natives] All page resize halos are moved synchroniously

Reported by: deyan Owned by:
Priority: major Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: deni Changelog:
Design_reviewers: meddle Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

Create some books, restore the windows and resize one of the pages. Watch what happens with the resize halos of the other windows - they move with halo that you are moving. See attached screenshouts.

Attachments

resizehalos.jpg (89.8 KB) - added by deyan 10 years ago.

Change History

Changed 10 years ago by deyan

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by deni

  • Status changed from s1b_analysis_finished to s2a_design_started

comment:3 follow-up: ↓ 4 Changed 10 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished
  • The problem is that currently PageResizeHaloMenu uses the current book to compute its location.
  • Instead, it should find its parent work area and use the model of the book view this work area displays.
  • Source code: [7123], [7124]

comment:4 in reply to: ↑ 3 Changed 10 years ago by deni

removed a warning in [7125]

comment:5 Changed 10 years ago by deni

  • Design_owners set to deni
  • Imp._owners set to deni
  • Analysis_reviewers set to deni

comment:6 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_score changed from 0 to 3.5
  • Imp._reviewers set to meddle
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3.5

Merged to the trunk in [7215]... Pap fixed that though, your way maybe is more cleaner, I don't know...

3.5p

comment:7 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

fixed

Note: See TracTickets for help on using tickets.