Ticket #2061 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

Frame titlebar is hidden when y pos is 0

Reported by: deyan Owned by: peko
Priority: critical Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners:
Imp._owners: peko Test_owners: vanya
Analysis_reviewers: peko Changelog:
Design_reviewers: meddle Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 3 Imp._score: 3
Test_score: 3

Description

Frame titlebar cannot be seen when frame position is < 0. There should be scrollbars that allow accessing the titlebar.

Attachments

2061.png (85.9 KB) - added by deyan 10 years ago.

Change History

Changed 10 years ago by deyan

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by todor

also when the frame position is (0,0) the frame is outside the page

comment:3 Changed 10 years ago by deyan

  • Priority changed from major to critical

comment:4 Changed 10 years ago by peko

  • Status changed from s1b_analysis_finished to s2a_design_started
  • Analysis_reviewers set to peko
  • Analysis_score changed from 0 to 3.5

comment:5 Changed 10 years ago by peko

  • Status changed from s2a_design_started to s2b_design_finished

The problem is that the actual view rectangle in the BaseSceneVisual computes itself given a rectangle and some padding. When however the title bar of the frame appears it is now included in the selection rectangle. In order to fix this we should increase the padding's y component so that it is visible when moved to coordinates <= 0.

comment:6 Changed 10 years ago by peko

  • Status changed from s2b_design_finished to s2c_design_ok

comment:7 Changed 10 years ago by peko

  • Owner set to peko
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:8 Changed 10 years ago by peko

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners set to peko

Bug fixed at 7440

comment:9 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 3
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3
  • Imp._reviewers set to meddle

I don't know if this is good fix, because the sticky resizes the area in not appropriate way (too large), but for the release, I think it passes.

Merged to the trunk at [7479].

3p (10m)

comment:10 Changed 10 years ago by vanya

  • Status changed from s3c_implementation_ok to closed
  • Test_owners set to vanya
  • Resolution set to fixed
  • Test_score changed from 0 to 3
Note: See TracTickets for help on using tickets.