Ticket #2116 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

layout-repaint -- Look And Feel in Java 5 does not repaint properly with transparent images.

Reported by: peko Owned by: peko
Priority: major Milestone: M12_RELEASE
Component: ui_consistency Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 73 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: peko Design_owners: peko
Imp._owners: peko Test_owners:
Analysis_reviewers: meddle Changelog:
Design_reviewers: meddle Imp._reviewers: meddle
Test_reviewers: Analysis_score: 2
Design_score: 2 Imp._score: 2
Test_score: 0

Description (last modified by deyan) (diff)

Transparent parts of the Look And Feel in Java 5 do not repaint properly. Mydoggy also has problems with flap tabs and title bars(because they are transparent as well).
Steps:

  1. Open sophie2.
  2. Click on a tab.
  3. The title bar of the flap is nor repainted properly. It should look as it looked when sophie was started.
  1. Create a new boook.
  2. Insert a script.
  3. Move the script window over the book window and its border looks ugly.

Same applies to huds and file menu. Although it is not easy to reproduce.

See comments.

Change History

comment:1 Changed 10 years ago by peko

  • Status changed from new to s2c_design_ok

comment:2 Changed 10 years ago by peko

  • Owner set to peko
  • Status changed from s2c_design_ok to s3a_implementation_started

The problem is connected with transparent images in the look and feel. All images in the look and feel that are transparent should be replaced in the java 1.5 xml file for the look and feel with non transparent ones. Mydggy should be tweaked so that its title bars and tabs repaint properly.

comment:3 Changed 10 years ago by peko

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Fixed in 7639

comment:4 Changed 10 years ago by meddle

  • Design_owners set to peko
  • Status changed from s3b_implementation_finished to new
  • Imp._owners set to peko
  • Analysis_reviewers set to meddle
  • Analysis_score changed from 0 to 2
  • Imp._reviewers set to meddle
  • Design_score changed from 0 to 2
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 2
  • Analysis_owners set to peko

The scripts still have bad borders, but some problems are fixed, Sophie is extremely slow under Java 5, but may be that is another bug, the tab of the bottom flap is not redrawn properly, I will add your code to the trunk, but the bug is not fixed.

Code added at [7664]. Branch deleted. To fix the bug branch from the trunk. From 2009-10-16 all the old branches will be banned for merging...

WRITE YOUR NAMES IN THE FIELDS!!!!!!!!!!

2p (40m)

comment:5 Changed 10 years ago by vanya

  • Status changed from new to s1b_analysis_finished
  • Description modified (diff)

comment:6 Changed 10 years ago by deyan

  • Importance set to 59
  • Summary changed from Look And Feel in Java 5 does not repaint properly with transparent images. to layout-repaint -- Look And Feel in Java 5 does not repaint properly with transparent images.

Batch update from file report_1.csv

comment:7 Changed 10 years ago by deyan

  • Priority changed from critical to major

Batch update from file 0911261.csv

comment:8 Changed 10 years ago by deyan

  • Component changed from uncategorized to ui_consistency

Batch update from file query.csv

comment:9 Changed 10 years ago by deyan

  • Description modified (diff)

Batch update from file active_tickets.csv

comment:10 Changed 10 years ago by deyan

  • Importance changed from 59 to 73

Batch update from file priorities8.csv

comment:11 Changed 8 years ago by meddle

  • Status changed from s1b_analysis_finished to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.