Ticket #2221 (closed unplanned_task: obsolete)

Opened 13 years ago

Last modified 11 years ago


Reported by: dido Owned by: meddle
Priority: major Milestone: X3
Component: MEDIA_CONTENT Version: 2.0
Keywords: Cc:
Category: END_PROD Effort:
Importance: 51 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: dido Design_owners: meddle
Imp._owners: meddle, stefan Test_owners:
Analysis_reviewers: deyan Changelog:
Design_reviewers: pap Imp._reviewers: pap, deyan
Test_reviewers: Analysis_score: 4
Design_score: 3.5 Imp._score: 3.5
Test_score: 0


Change History

comment:1 Changed 13 years ago by dido


comment:2 Changed 13 years ago by dido

  • Owner set to dido
  • Status changed from new to s1a_analysis_started

comment:3 Changed 13 years ago by dido

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:4 Changed 13 years ago by deyan

  • Importance set to 15
  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to deyan
  • Analysis_owners set to dido
  • Analysis_score changed from 0 to 4

comment:5 Changed 13 years ago by dido

  • Importance changed from 15 to 51

comment:6 Changed 13 years ago by tsachev

  • Design_owners set to tsachev
  • Owner changed from dido to tsachev
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:7 Changed 13 years ago by meddle

  • Design_owners changed from tsachev to meddle
  • Status changed from s2a_design_started to s2b_design_finished

comment:8 Changed 13 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to pap
  • You dropped the requirement for "remember settings" checkbox without writing any reason why. You usually fail tasks for that.
  • I think you should've written that you'll change the BookInfo class too :)
  • I think modifyLooped is a better name than setLooped (we use this kind of "convention" in other immutables) as set gives tha notion of mutability.
  • I like that you added a toString of BookInfo
  • Some commented out code in BookTimeState. I hope this will get fixed in implementation.
  • A bit short :)

comment:9 Changed 13 years ago by meddle

  • Owner changed from tsachev to meddle
  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to meddle

Yeah, a bit short, but as a code that was the fix... as a fight with the media was very hard, though...
About the BookInfo, you are right, but you are murmuring again...
About the dropped thing, I didn't drop a whole requirement, and it's stupid for me :P
The modifyLooped is setLooped, because the other methods in the class were setStuff... I can not fix code now, because the task must be ready today...
The comments are cleared in the second or the third commit I think...

comment:10 Changed 13 years ago by meddle

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners changed from meddle to meddle, stefan

comment:11 Changed 13 years ago by pap

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 0 to 3.5
  • Imp._reviewers set to pap, deyan
  • I don't understand very well what the pageToBookTime private method in BookTimeState does. Actually I do understand but it could be better named and could have some sort of comment to describe it.
  • I don't like the way you split the getPageTime method of BookView in two rows - it is ugly.
  • I personally would like if we had all methods(even private) documented somehow.
  • I told you about how to use equals with constants.

comment:12 Changed 11 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.