Ticket #2233 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

deleting-annotation-sets - When there are several anotation sets and you try to delete one, exception is thrown.

Reported by: todor Owned by:
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 83 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: deni Changelog:
Design_reviewers: meddle Imp._reviewers: meddle, todor
Test_reviewers: Analysis_score: 4
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

  • Open book or create a new one.
  • Add three book extras.
  • You'll notice that they're not alphabetically ordered.
  • Select one of the extras and try to delete it.

As a result exception is thrown instead of deleting the selected book extra.

Attachments

delete-annotation-sets.patch (920 bytes) - added by deni 10 years ago.

Change History

comment:1 Changed 10 years ago by todor

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by deyan

  • Importance set to 83

comment:3 Changed 10 years ago by deni

  • Status changed from s1b_analysis_finished to s2a_design_started

comment:4 Changed 10 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished

Changed 10 years ago by deni

comment:5 Changed 10 years ago by deni

  • Design_owners set to deni
  • Imp._owners set to deni
  • Analysis_reviewers set to deni
  • Analysis_score changed from 0 to 4
  • the problem was caused by a stupid mistake in BookExtrasState.remove(ResourceRefR4) - used a ref to the annotation that will be deleted instead of the current annotation... :-(
  • I could not make them alphabetically ordered, but since it is not related to deleting annotation sets, we can make a separate ticket.

comment:6 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3.5
  • Imp._reviewers set to meddle, todor

Committed in [8471].

Fixed the order to be lexicographic.

3.5p

comment:7 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.