Ticket #2276 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

save-as-resets-book-window -- On save as book window options are lost

Reported by: deyan Owned by: deni
Priority: major Milestone: X3
Component: ui_consistency Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 45 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: deni Changelog: Changelog
Design_reviewers: meddle Imp._reviewers: meddle, todor, deyan, todor, pap
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3.5
Test_score: 0

Description (last modified by deyan) (diff)

On save as, the working dialog should show the progress. Book window should be at the same location.

Attachments

book-window-location-lost-on-save-as.patch (837 bytes) - added by deni 9 years ago.
book-window-location-lost-on-save-as-2.patch (6.8 KB) - added by deni 9 years ago.

Change History

comment:1 Changed 10 years ago by dido

  • Category set to unknown
  • Analysis_score set to 0
  • Importance set to 45
  • Test_score set to 0
  • Design_score set to 0
  • Imp._score set to 0

comment:2 Changed 9 years ago by deyan

  • Component changed from uncategorized to ui_consistency

Batch update from file query.csv

comment:3 Changed 9 years ago by deyan

  • Status changed from new to s1b_analysis_finished
  • Description modified (diff)

Batch update from file active_tickets.csv

comment:4 Changed 9 years ago by deni

  • Design_owners set to deni
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to deni
  • Analysis_reviewers set to deni
  • Changelog set to [wiki:Changelog]
  • Analysis_score changed from 0 to 3
  • Losing book window options and showing a progress bar on 'save as' are not connected and should be in different tickets. Besides, the ticket's name has nothing to do with the progress bar.


  • I'll fix the following problem: on 'save as' the location of the book window is changed - it moves a bit down and right. There is no problem with the size.

Changed 9 years ago by deni

comment:5 Changed 9 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished
  • In BookDocView.reopen(ResourceAccess) first remove the current view from the main window's documents and after that add the new view. In this way the old view will make space for the new one.

comment:6 Changed 9 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 3
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3
  • Imp._reviewers set to meddle, todor, deyan

Merged to the trunk at [8830].

It doesn't fix the moving from the center of the PWA to its top-left edge when saving as, but it introduces some fixes, so passes.

comment:7 Changed 9 years ago by deni

  • Status changed from s3c_implementation_ok to s1c_analysis_ok
  • Moving to analysis_ok, because the book window always moves to the top left corder.

comment:8 Changed 9 years ago by deni

  • Owner set to deni
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:9 Changed 9 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished
  • Repeat the solution of the same problem for the size of the window:
    • Add a rw property holding the last window location in DocView - preferredLocation.
    • Add a new setup property to MDDocumentWindow.swingComponent() that synchronizes the JInternalFrame's location with its model's preferred location.
    • In the ComponentListener for the JInternalFrame in MDDocumentWindow, set the property to the window's location when it moves.
    • In BookDocView.reopen(ResourceAccess) set the preferred location of the new view to the location of the old one.

Changed 9 years ago by deni

comment:10 Changed 9 years ago by pap

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 3 to 3.5
  • Imp._reviewers changed from meddle, todor, deyan to meddle, todor, deyan, todor, pap
  • Commited in [8915].
  • Ok but this showed some strange behavior of document windows. But these are not caused by your code.
  • The new property as well as the old one about the size should be in the base abstract class DefaultDocView instead of the concrete implementations.

comment:11 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.