Ticket #2292 (closed bug: later)

Opened 10 years ago

Last modified 10 years ago

mac issue: keyboard shortcuts in bug reporting interface are wrong

Reported by: danvisel Owned by:
Priority: minor Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 90 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: danvisel Design_owners:
Imp._owners: Test_owners:
Analysis_reviewers: Changelog: Changelog
Design_reviewers: Imp._reviewers:
Test_reviewers: Analysis_score: 0
Design_score: 0 Imp._score: 0
Test_score: 0

Description (last modified by todor) (diff)

  1. Open Sophie on a Mac.
  2. Select Help > Send an Error Report
  3. Insert cursor in the top field, where the log is.
  4. Press command-A to select all.

Result: nothing happens. However: if you press control-A to select all, everything is selected; control-C will let you copy things.

The problem is that Mac users expect that keyboard shortcuts use the command key rather than the control key; this seems to be the case everywhere else in the interface. This has been a problem for bug reporting: a couple of users have told me that they could get an error report, but that they couldn't copy and paste it into an email because select all & copy don't work. When I tell them to use "control", it works; however, users wouldn't think to do that by themselves.

Solution: remap "control" key to "command" in this interface.

Change History

comment:1 Changed 10 years ago by danvisel

  • Status changed from new to s1b_analysis_finished
  • Summary changed from mac issue: keyboard shortcuts in bug reporting interface are strange to mac issue: keyboard shortcuts in bug reporting interface are wrong

comment:2 Changed 10 years ago by danvisel

Willy reports that this is also the case with the URL field in the link HUD:

(Mac Only Bug) When trying to paste a url in the link window on a Mac using the normal shortcut paste keys (command + v) it doesn’t paste it in the “Open URL” box. It actually gets pasted on the text window you are trying to create the link for. If I use the PC shortcut for paste (control + v) it works, but that’s not normal for Mac users.

I suspect this is also the case other places in the interface on the Mac, though the usual keyboard shortcuts work correctly when copying and pasting text or frames.

comment:3 Changed 10 years ago by dido

  • Importance set to 90

comment:4 Changed 10 years ago by deyan

  • Description modified (diff)

Batch update from file active_tickets.csv

comment:5 Changed 10 years ago by todor

  • Status changed from s1b_analysis_finished to closed
  • Resolution set to later
  • Description modified (diff)
  • Changelog set to [wiki:Changelog]
Note: See TracTickets for help on using tickets.