Ticket #2314 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

Script window closing

Reported by: kyli Owned by: mira
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 80 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: kyli Design_owners: mira
Imp._owners: mira Test_owners:
Analysis_reviewers: mira Changelog: Changelog
Design_reviewers: meddle Imp._reviewers: meddle, todor
Test_reviewers: Analysis_score: 3
Design_score: 4 Imp._score: 4
Test_score: 0

Description

  1. Start Sophie2, create a new book.
  2. Select the book, click edit->script
  3. Try to close Sophie2. Exceptions occurs.

Attachments

bug report.txt (19.7 KB) - added by kyli 10 years ago.
scriptClosing.patch (4.5 KB) - added by mira 10 years ago.
implementation

Change History

Changed 10 years ago by kyli

comment:1 Changed 10 years ago by kyli

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by mira

  • Design_owners set to mira
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to mira
  • Analysis_reviewers set to mira
  • Analysis_score changed from 0 to 3

comment:3 Changed 10 years ago by mira

  • Status changed from s2a_design_started to s2b_design_finished

The problem is that whenever a script is opened it uses the same access with the same view oprions as the book. This is not good but it is needed because of the scripting implementation.
If there are two views to the same master access for a script an exception occurs related to the synchronization of the script text and text area of the view.
Also the analists think it is good behaviour that whenever you try to open a script a single window is opened or made current.

So I am going to fix this with two changes:

  1. I am going to fire and handle an event when a book window is closed. The logic is to close all related windows. In this case - the script that is part of the book.
  2. When closing access make sure that it is BookDocView and not access to some inner resource.

comment:4 Changed 10 years ago by mira

  • Status changed from s2b_design_finished to s2c_design_ok

comment:5 Changed 10 years ago by mira

  • Owner set to mira
  • Status changed from s2c_design_ok to s3a_implementation_started

Changed 10 years ago by mira

implementation

comment:6 Changed 10 years ago by mira

  • Status changed from s3a_implementation_started to s3b_implementation_finished

The implementation is made according to the desing. There is a patch file attached.

comment:7 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to meddle, todor

Good, but the lists have removeAll method and the event parameter indexes must be constants.

comment:8 Changed 10 years ago by meddle

  • Cc meddle removed
  • Changelog set to [wiki:Changelog]

comment:9 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.