Ticket #2379 (closed bug: obsolete)

Opened 10 years ago

Last modified 9 years ago

sophie-system-requirements - Create list with the system requirements for Sophie.

Reported by: todor Owned by: todor
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: todor
Imp._owners: Test_owners:
Analysis_reviewers: deyan Changelog: Changelog
Design_reviewers: meddle Imp._reviewers:
Test_reviewers: Analysis_score: 2
Design_score: 3.5 Imp._score: 3
Test_score: 0

Description (last modified by todor) (diff)

Create lists with the system requirements that must be fulfilled in order to run Sophie. The first list must be for the minimum requirements, the second for the recommended.

  • Hardware
    • CPU
    • RAM
    • Disk Space
    • Soundcard
  • Software
    • OS
    • Java Version
  • Additional things (if needed).

Change History

comment:1 Changed 10 years ago by todor

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by deyan

  • Status changed from s1b_analysis_finished to new
  • Analysis_reviewers set to deyan
  • Analysis_score changed from 0 to 2

Should have minimum and recommended requirements.

comment:3 Changed 10 years ago by todor

  • Status changed from new to s1b_analysis_finished
  • Description modified (diff)

comment:4 Changed 10 years ago by todor

  • Status changed from s1b_analysis_finished to s2a_design_started

Below are the requirements, create page in the wiki, which contains them.

  • Minimum Requirements
    • OS: Linux / Windows XP, Vista, 7 / Mac OSX 10.5, 10.6
    • Java Version: java 1.5
    • Processor: 800MHz Intel/AMD
    • RAM: 512 MB DDR2 (1024 MB DDR2 for Windows Vista, 7)
    • VGA
    • HDD Space: 100 MB
  • Recomended Requirements
    • OS: Linux / Windows XP, Vista, 7 / Mac OSX 10.5, 10.6
    • Java Version: java 1.6
    • Processor: 1,6GHz Intel Core 2 Duo or AMD equivalent
    • RAM: 1024 MB DDR2 (2048 MB DDR2 for Windows Vista, 7)
    • HDD Space: 200 MB
    • VGA, Audiocard, Microphone

comment:5 Changed 10 years ago by todor

  • Status changed from s2a_design_started to s2b_design_finished

comment:6 Changed 10 years ago by todor

  • Design_owners set to todor

comment:7 Changed 10 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle

Think it passes for design of that task. But why the analysis has two points and passed?? And you could put for example description (this is design after all) why you chose the minimum processor requirements to be 800MHz. Something like, I tested it with some machine (OS, Environment, etc) and I had problems...

comment:8 Changed 10 years ago by todor

  • Owner set to todor
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:9 follow-up: ↓ 10 Changed 10 years ago by todor

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:11 Changed 10 years ago by deyan

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 0 to 3

I have several comments

  • This task is not a bug
  • It is not written anywhere that these requirements were actually tested
  • There are issues with some operating systems that have to be tested before saying that it is a recoomended system

comment:12 Changed 9 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.