Ticket #739 (closed planned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago

FRAME_BOUNDS_R0

Reported by: Astea Owned by: mira
Priority: 3 Milestone: M03_PRE3
Component: FRAME_PROPERTIES Version: 2.0
Keywords: Cc:
Category: MAIN Effort: 0.5
Importance: 15 Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: mira Design_owners: mira
Imp._owners: mira Test_owners:
Analysis_reviewers: tanya Changelog:
Design_reviewers: -meddle, tanya, tanya Imp._reviewers: tanya, jani
Test_reviewers: Analysis_score: 3
Design_score: 3.5 Imp._score: 3
Test_score: 0

Description

wiki page: FRAME_BOUNDS_R0 - effort: 0.5d

Change History

comment:1 Changed 14 years ago by deyan

  • Category set to MAIN
  • Design_score set to 0
  • Imp._score set to 0
  • Test_score set to 0
  • Analysis_score set to 0

Adding category

comment:2 Changed 14 years ago by Tanya

  • Importance changed from 0 to 15

comment:3 Changed 14 years ago by mira

  • Owner changed from Astea to mira
  • Status changed from new to s1a_analysis_started
  • Analysis_owners set to mira

comment:4 Changed 14 years ago by mira

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:5 Changed 14 years ago by tanya

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to tanya
  • Analysis_score changed from 0 to 3

Be careful when writing task requirements of a task. Is everything written possible to be completed during this revision? You can just mark some of the task as optional. When writing the "How to demo" section do not use some things that are connected with the implementation idea. For example "Demonstrate the enums" is not appropriate because the implementor can decide not to use enums.

comment:6 Changed 14 years ago by mira

  • Design_owners set to mira
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:7 Changed 14 years ago by mira

  • Status changed from s2a_design_started to s2b_design_finished

comment:8 Changed 14 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle

The link to the test was not working, but I fixed it. (20m)

comment:9 Changed 14 years ago by mira

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:10 Changed 14 years ago by mira

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:11 Changed 14 years ago by mira

  • Imp._owners set to mira

comment:12 Changed 14 years ago by tanya

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 0 to 2
  • Imp._reviewers set to tanya
  • setSize, setLocation don't have summary in the java doc what actually these methods do.
  • setSize, setLocation, setRect should be in the Frame class.
  • setSize (and the other methods) is not good name because you don't set size to anything, you just calculate and return ImmPoint.
  • getCommonInset doesn't have java doc. It doesn't matter that it is a private method because it is not so trivial and it is difficult to understand what this method is about. What is more, I think that this method is not very correct. I think that MID_BORDER and OUT_BORDER should switch their places.
  • Always use Ctrl+Shift+F to reformat.
  • TestBoundMode could be better if the three tests it has are broken into many smaller tests. What is more, there is no unit test that tests integration of insets with frame.

comment:13 Changed 14 years ago by tanya

  • Status changed from s2c_design_ok to s1c_analysis_ok
  • Design_score changed from 3.5 to 2
  • Design_reviewers changed from meddle to -meddle, tanya
  • Bad names - setSize, setLocation
  • The unit test is not a demo unit test.

comment:14 Changed 14 years ago by mira

  • Status changed from s1c_analysis_ok to s2a_design_started

comment:15 Changed 14 years ago by mira

  • Status changed from s2a_design_started to s2b_design_finished

comment:16 Changed 14 years ago by tanya

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 2 to 3.5
  • Design_reviewers changed from -meddle, tanya to -meddle, tanya, tanya
  • It is OK.

comment:17 Changed 14 years ago by mira

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:18 Changed 14 years ago by mira

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:19 Changed 14 years ago by jani

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 2 to 3
  • Imp._reviewers changed from tanya to tanya, jani
  • Good job.
  • It is better to link changesets instead of classes. It will be much easier for the reviewer, and changes to other classes will also be visible.
  • A don't like the names of the set* methods. Maybe calculate* (e.g. calculateSize) is better.

comment:20 Changed 13 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.