Ticket #771 (closed planned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago

FRAME_FILLING_PATTERN_R0

Reported by: Astea Owned by: sveto
Priority: 3 Milestone: M05_PRE5
Component: FRAME_PROPERTIES Version: 2.0
Keywords: Cc: sveto
Category: MAIN Effort: 1
Importance: 0 Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: danvisel Design_owners: sveto, sveto
Imp._owners: sveto Test_owners:
Analysis_reviewers: deyan Changelog:
Design_reviewers: pap, pap Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 3 Imp._score: 3
Test_score: 0

Description

wiki page: FRAME_FILLING_PATTERN_R0 - effort: 1d

Change History

comment:1 Changed 14 years ago by mira

  • Owner changed from Astea to mira
  • Design_score set to 0
  • Imp._score set to 0
  • Test_score set to 0
  • Analysis_score set to 0

comment:2 Changed 14 years ago by mira

  • Status changed from new to s1a_analysis_started
  • Analysis_owners set to mira

comment:3 Changed 14 years ago by mira

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:4 Changed 13 years ago by pav

  • Ticket_group set to GROUP_FILLING_R0

comment:5 Changed 13 years ago by pav

  • Ticket_group GROUP_FILLING_R0 deleted

comment:6 Changed 13 years ago by deyan

  • Status changed from s1b_analysis_finished to new

Batch update from file query-1.csv

comment:7 Changed 13 years ago by danvisel

  • Owner changed from mira to danvisel
  • Status changed from new to s1a_analysis_started
  • Analysis_owners changed from mira to danvisel

comment:8 Changed 13 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

Analysis redone - I'm not sure if I've done this correctly, as this is my first coding analysis.

comment:9 Changed 13 years ago by danvisel

Reworked this with Pav's comments - thanks.

comment:10 Changed 13 years ago by deyan

  • Status changed from s1b_analysis_finished to new
  • Analysis_score changed from 0 to 2

The analysis contains good overview, but since the effort of the task is small, the requirements should contain only what can be done in this revisions. The behavior will be little different from Sophie 1 since we do have filling type Image.

  • In overview you should describe what is the expected behavior of the functionality in this revision or for the whole task. In task requirements you should point what exactly is expected in this revision.
  • Choosing pattern should tile the image with it's default size. Due to the effort, resizing the image, rotating and the offset should be postponed (described in the overview section only)
  • Since we don't currently support drag and drop, clicking on pattern should trigger an File Dialog to choose file from the OS (like insert image and filling:image) (this one is for the requirements - for future releases the DND is good, but should be in the overview section)

comment:11 Changed 13 years ago by deyan

  • Analysis_reviewers set to deyan

comment:12 Changed 13 years ago by danvisel

  • Status changed from new to s1a_analysis_started

comment:13 Changed 13 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

Reworked analysis with Deyan's comments and Pav's help.

comment:14 Changed 13 years ago by danvisel

time for reworking = 1h.

comment:15 Changed 13 years ago by deyan

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_score changed from 2 to 3.5
  • The button may contain currently selected pattern
  • The image is with it's default size tiled

comment:16 Changed 13 years ago by sveto

  • Owner changed from danvisel to sveto
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:17 Changed 13 years ago by sveto

  • Status changed from s2a_design_started to s2b_design_finished

comment:18 Changed 13 years ago by pap

  • Cc sveto added
  • Design_owners set to sveto
  • Design_reviewers set to pap
  • Status changed from s2b_design_finished to s1c_analysis_ok
  • Design_score changed from 0 to 2.5

You are on the right path but there are some things that you should fix.

  • ImmPattern should rather use our class ImmImage instead of BufferedImage. This way you will not have to wrtite the same things twice. You can use its transformaton methods too.
  • Also I don't think it is needed to extend FileDialogInput.Kind enumeration. You'd better use the INSERT_IMAGE. This dialog should be refactored but in another task.
  • Your test about immutability is a should test more things than now.

comment:19 Changed 13 years ago by sveto

  • Status changed from s1c_analysis_ok to s2a_design_started

comment:20 Changed 13 years ago by sveto

  • Status changed from s2a_design_started to s2b_design_finished

comment:21 Changed 13 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 2.5 to 3
  • Design_reviewers changed from pap to pap, pap
  • I accept the design even though it has some flaws.
  • Note that you should also change the PageWorkArea to consider the new filling type
  • I do not fully understand why do you need to create a pattern from file (I mean the constructor).
  • Make sure that you fix the sizes of the BackgroundAndBorderHud and BackgroundPanel so that they display all 4 filling type selectors(this is a bit OS/java setup dependent).
  • By default in the design you should submit some skeleton classes as much as they are needed for testing and not a fully working implementation.
  • Next time try to do separate commits for the design part and the implementation part of the code.
  • I will merge and review all of your code at implementation because what you submitted definitely differs from what the UML diagram states.
  • Good luck and ask for help if you need to. So far you're doing well for a person new to the project.
  • And a little note: Please make sure that you fill in the so called "custom fields" like Design_owners. You can ask about the way they should be used.

comment:22 Changed 13 years ago by sveto

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:23 Changed 13 years ago by sveto

  • Imp._owners set to sveto

comment:24 Changed 13 years ago by sveto

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:25 Changed 13 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 0 to 3
  • Imp._reviewers set to meddle

I'll pass the implementation, but I fixed somethings:

  • First of all when clicking cancel on the file dialog for choosing the image for the pattern, an exception was thrown (that is and for the ImageFilling), I fixed that.
  • Other thing is the strange constructor for pattern from file. The code was copied from the ImmImage file constructor and the ImmPattern ImmImmage constructor, I removed it.
  • Why do you write first assertEquals(something) and then asserSame(the_same_thing), assertSame is stronger than assertEquals.

3p (80m)

comment:26 Changed 13 years ago by sveto

  • Status changed from s3c_implementation_ok to s4a_test_started

comment:27 Changed 13 years ago by sveto

  • Status changed from s4a_test_started to s4b_test_finished

comment:28 Changed 13 years ago by sveto

  • Test_owners set to sveto

comment:29 Changed 13 years ago by sveto

  • Design_owners changed from sveto to sveto, sveto

comment:30 Changed 13 years ago by sveto

  • Test_owners sveto deleted

comment:31 Changed 13 years ago by deyan

  • Status changed from s4b_test_finished to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.