Ticket #794 (closed planned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago

FRAME_CONTENT_R0

Reported by: Astea Owned by: alex
Priority: 3 Milestone: M03_PRE3
Component: FRAME_PROPERTIES Version: 2.0
Keywords: Cc:
Category: MAIN Effort: 1
Importance: 20 Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: alex Design_owners: alex, alex
Imp._owners: alex, alex Test_owners:
Analysis_reviewers: peko Changelog:
Design_reviewers: tanya,pap,pap Imp._reviewers: pap, jani
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3
Test_score: 0

Description

wiki page: FRAME_CONTENT_R0 - effort: 1d

Change History

comment:1 Changed 14 years ago by deyan

  • Category set to MAIN
  • Design_score set to 0
  • Imp._score set to 0
  • Test_score set to 0
  • Analysis_score set to 0

Adding category

comment:2 Changed 14 years ago by Tanya

  • Importance changed from 0 to 20

comment:3 Changed 14 years ago by alex

  • Owner changed from Astea to alex
  • Status changed from new to s1a_analysis_started
  • Analysis_owners set to alex

comment:4 Changed 14 years ago by alex

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:5 Changed 14 years ago by peko

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to peko
  • Analysis_score changed from 0 to 3

comment:6 Changed 14 years ago by peko

It is generally OK. The score is 3p because the task requirements section overlaps the overview section. It is understandable what should be done but it is not well structured. A little more information can be added. Ensure this is done in design section.

comment:7 Changed 14 years ago by meddle

  • Owner changed from alex to meddle
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:8 Changed 14 years ago by alex

  • Design_owners set to alex
  • Status changed from s2a_design_started to s2b_design_finished

comment:9 Changed 14 years ago by alex

  • Analysis_owners changed from alex to ale

comment:10 Changed 14 years ago by alex

  • Analysis_owners changed from ale to ales

comment:11 Changed 14 years ago by alex

  • Analysis_owners changed from ales to alex

comment:12 Changed 14 years ago by tanya

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3
  • Design_reviewers set to tanya
  • Change the parent property of the FrameContent. It is Frame not FrameContent.
  • "How to demo" should be use case, not unit test. What is more, do not changed the analysis after it has pass review. Because it is extra time, and it is possible to be wrong after that.

comment:13 Changed 14 years ago by alex

  • Owner changed from meddle to alex
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:14 Changed 14 years ago by alex

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:15 Changed 14 years ago by pap

  • Status changed from s3b_implementation_finished to s1c_analysis_ok
  • Design_score changed from 3 to 2
  • Design_reviewers changed from tanya to tanya,pap
  • Imp._score changed from 0 to 2
  • Imp._reviewers set to pap
  • Design issues:
    • The FrameContent class is part of BASE_MODEL_FRAME_CONTENT task, so it is already existing
    • You should define how the ContentView of each FrameContent is to be created
    • The FrameView class may be responsible for creating the ContentView corresponding to its FrameContent, but as you are implementing the concept of ContentView it is your responsibility to add this functionality to the FrameView
    • You should define how non-defined content is going to be handled(displayed). Now non-defined content is represented as a Frame whose content property holds a null
    • Perhaps it's not a good idea not to have a ContentView at all as the user would like to see something.
    • You should define how content replacement is going to be handled.
    • Is it really necessary for the ContentView to know its parent FrameView? From what I see in the requirements of the task I don't see any use of that. You could discuss this with someone else.
  • Implementation issues
    • The ContentViewFactory is not well designed. It seems stateless so its createContentView better be static.
    • This could make the contentViewFactory property of the FrameViewToDo class useless.
    • The createContentView method of the ContentViewFactory class has an useless final modifier to its argument
    • The compute method of the contentViewFactory property of the FrameViewToDo class should have an "assert getLastValue() == null;" statement. This is a general advice when using auto properties as one time set value properties.
    • It depends on the way you redesign content view creation but the compute method of the contentView property of the FrameViewToDo class may lead to some ambiguity. I mean that null value may mean different things. This could also be discussed.
    • The ContentViewTest should have methods that test content replacement and non-defined content. You actually have something like that but it's all in one test method.
    • In the ContentViewTest in the DummyContentView class it is a bad idea to use a value property the way you do with element(). The problem is that a new DefaultSceneElement will be created each time that you query the value of the property as long as you haven't set it to a non-null one.
    • I don't get the idea of the DummyFrameView class. The JavaDoc says about problems but it doesn't mention them.
  • General issues
    • It is better if you link changesets in the result. It makes reviewing much easier.
    • Also you didn't show all the classes that you made changes to.
    • The testing section is about manual tests (the testing phase of each task).
    • Unit tests should be linked in the implementation section. Perhaps you could create a subsection if you think this makes the page look better.
    • Make sure you keep the wiki page of the task up-to-date with all the changes. High quality documentation is very important.

comment:16 Changed 14 years ago by alex

  • Status changed from s1c_analysis_ok to s2a_design_started

comment:17 Changed 14 years ago by alex

  • Status changed from s2a_design_started to s2b_design_finished

comment:18 Changed 14 years ago by alex

  • Design_owners changed from alex to alex, alex

comment:19 Changed 14 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 2 to 3
  • Design_reviewers changed from tanya,pap to tanya,pap,pap
  • It is sufficient, but you should write more descriptive designs.
  • Also I suppose that by template type you mean a generic. Please use correct terminology

comment:20 Changed 14 years ago by alex

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:21 Changed 14 years ago by alex

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners set to alex, alex

comment:22 Changed 14 years ago by jani

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 2 to 3
  • It looks OK.
  • Currently, UndefinedContentView is implemented as an empty image (ImageSceneElement). This is a subject to change.
  • Please link all the changesets that are related to this task, even if there are minor corrections to some classes.

comment:23 Changed 14 years ago by jani

  • Imp._reviewers changed from pap to pap, jani

comment:24 Changed 13 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.