Ticket #849 (closed planned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago

SEARCH_COMMONS_R0

Reported by: Astea Owned by: diana
Priority: 3 Milestone: M03_PRE3
Component: TEXT_TOOLS Version: 2.0
Keywords: Cc:
Category: EXTRA Effort: 1
Importance: 5 Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: dido, diana Design_owners: diana
Imp._owners: Test_owners:
Analysis_reviewers: deyan Changelog:
Design_reviewers: meddle, dido, mitex Imp._reviewers: meddle, meddle, meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

wiki page: SEARCH_COMMONS_R0 - effort: 1d

Attachments

search-selection.txt (11.4 KB) - added by meddle 13 years ago.
Error with stickies
chaining-highlight.txt (6.4 KB) - added by meddle 13 years ago.

Change History

comment:1 Changed 14 years ago by Tanya

  • Category set to EXTRA
  • Design_score set to 0
  • Imp._score set to 0
  • Test_score set to 0
  • Analysis_score set to 0

comment:2 Changed 14 years ago by Tanya

  • Importance changed from 0 to 5

comment:3 Changed 14 years ago by mitex

  • Owner changed from Astea to mitex

comment:4 Changed 14 years ago by mitex

  • Status changed from new to s1a_analysis_started
  • Analysis_owners set to mitex

comment:5 Changed 14 years ago by mitex

  • Status changed from s1a_analysis_started to s1b_analysis_finished

analysis finished

comment:6 follow-up: ↓ 7 Changed 14 years ago by gogov

  • Status changed from s1b_analysis_finished to new
  • Analysis_reviewers set to gogov
  • Analysis_score changed from 0 to 2.5

Here's a list of some stuff which isn't right:

  • There's no need to paste the rough descriptions from the WBS in the Overview section
  • Lots of stuff which you've included in the task Task requirements is actually for the Overview section. Task requirements should include concrete list of things the designer/implementor should complete.
  • You use bullets, which is good, though you could use them even more: "Text is typed in the field at the top of the palette and Enter is hit. A list of all occurrences in text are provided in the palette; to go to one of them, it is clicked in the list. Clicking on a result displays the page of the book with the match. The caret is positioned at the beginning of the match. The match is highlighted." could be bulleted and it'd be much more readable.
  • You could consider splitting the long sections like Task requirements in subsections if necessary to enforce a more structured view on things that need to be done.
  • When requesting a concept, or design or strategy of a new feature to be developed it's OK to list diagrams, unit tests, further explanations as requirements and task results.

You're on a right track, though I guess paying more attention to PLATFORM_STANDARDS_ANALYSIS would help writing better analysis.

comment:7 in reply to: ↑ 6 Changed 14 years ago by mitex

OK, I'll improve my analysis.

Actually, according to PLATFORM_STANDARDS_ANALYSIS:
"it is recommended to have a code block including the description of the task that is found in the /manage/sched/sophie2_wbs.py file."
Maybe this requirement hasn't been present in previous versions of this wiki page.

comment:8 Changed 14 years ago by mitex

  • Status changed from new to s1a_analysis_started

start an2

comment:9 Changed 13 years ago by mitex

  • Status changed from s1a_analysis_started to new

comment:10 Changed 13 years ago by meddle

  • Design_owners set to diana
  • Analysis_reviewers changed from gogov to deyan
  • Analysis_owners changed from mitex to dido, diana
  • Analysis_score changed from 2.5 to 3.5

By menu in the requirements you probably mean dialog. This should be later moved to a palette. deyan

comment:11 Changed 13 years ago by meddle

  • Status changed from new to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle, dido, mitex
  • You know my comments about the code :) For the implementation this will be important.
  • The task was wrong.
  • There is no need of creating search menu item (and dialog window). If you like to implement quick search functionality make this in a proper way by using the correct palette. However in 'How to' section from the analysis the demonstration for the highlight is with selection not with search.(dido)
  • Remove the dialog boxes and menu item move this functionality inside the palette.(dido)
  • Discuss that with me and dido :)

3.5p (70m)

comment:12 Changed 13 years ago by diana

  • Owner changed from mitex to diana
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:13 Changed 13 years ago by diana

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Changed 13 years ago by meddle

Error with stickies

comment:14 Changed 13 years ago by meddle

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 0 to 2.5
  • Imp._reviewers set to meddle

I'll fail it now, because there is a strange error (see the attachment) when inserting sticky. I tried that because Stickies also contain hot text, which can be selectable... I think it is connected to the highlights and the activation channels of the timelines.
And can you tell me how to test the quick search if there is such, because the field bellow the book for searching don't work.

2.5p (70m)

comment:15 Changed 13 years ago by diana

  • Status changed from s2c_design_ok to s3a_implementation_started

The quick search works after you have typed word in the field below the book and selected the frame that you want to search the text in, position the cursor somewhere in the text and press one of the buttons(prev/next). I suppose you haven't selected the frame.
Can you tell me the steps (one by one) causing this error because I cannot reproduce it.

comment:16 Changed 13 years ago by diana

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Changed 13 years ago by meddle

comment:17 Changed 13 years ago by meddle

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 2.5 to 2
  • Imp._reviewers changed from meddle to meddle, meddle
  • Behavior problems:
    • The highlight doesn't work in reader and preview.
    • When you go ahead with the next button the highlight selects one word after the cursor, then on the second next another word, bu if in this moment you press the prev button it doesn't select the previously highlighted word, that was after the cursor....
  • Problems with crashes:
    • The highlight code crashes the chaining. See the attachment chaining-highlight.txt for the exception.

2p (3h)

comment:18 Changed 13 years ago by diana

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:19 Changed 13 years ago by diana

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:20 Changed 13 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 2 to 3.5
  • Imp._reviewers changed from meddle, meddle to meddle, meddle, meddle

Merged at last...

  • Hehe the highlight class :)
  • And there is a small bug with the selection into the trunk, if you fix it I'll be happy :) But after all this time:

3.5p (100m)

comment:21 Changed 13 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.