wiki:PLATFORM_NFR_COMPATIBILITY
Last modified 11 years ago Last modified on 11/12/08 16:48:45

These are the hardware, software and platform requirements for running Sophie2. They can change through the development process.

Hardware Requirements

Sophie 2.0 can run on a machine with the following hardware characteristics:

  • 2 GHz 32-bit (x86) or 64-bit (x64) processor
  • 1 GB of system memory (512 MB minimal requirement)
  • Screen resolution: 1024x768 pixels (minimal requirement)

Software Requirements

Sophie 2.0 can run on a machine with the following software characteristics:

There will be no bundled software.

Supported Platforms

  • Windows 2000/NT/XP/Vista 32/64 bits
  • Linux
  • FreeBSD (optional)
    • We can do it but it is not a target
  • MacOS 10.4 Tiger or later

Platform Independent Requirements

Platform independent software libraries and products needed for running Sophie 2.0:

  • Java 5 (or higher if it is available for all the platforms)

Platform Dependent Requirements

Platform depend (native) software libraries and products needed for running Sophie 2.0:

  • web browser (which depends on the libraries we use for implementation) for browser content
    • it will be specified later in the development process
  • web browser and flash player for flash content
    • it will be specified later in the development process