Ticket #1662 (closed unplanned_task: obsolete)

Opened 14 years ago

Last modified 13 years ago


Reported by: pav Owned by: pav
Priority: major Milestone: M06_ALPHA1
Component: PLUGIN_ARCHITECTURE Version: 2.0
Keywords: Cc:
Category: PLATFORM Effort:
Importance: Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: pav Design_owners: pav
Imp._owners: Test_owners:
Analysis_reviewers: boyan Changelog:
Design_reviewers: pap Imp._reviewers:
Test_reviewers: Analysis_score: 3.5
Design_score: 3.5 Imp._score: 0
Test_score: 0

Change History

comment:1 Changed 14 years ago by pav

  • Status changed from new to s1a_analysis_started
  • Analysis_owners set to pav

comment:2 Changed 14 years ago by pav

  • Status changed from s1a_analysis_started to s1b_analysis_finished


comment:3 Changed 14 years ago by boyan

  • Category changed from unknown to PLATFORM
  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to boyan
  • Analysis_score changed from 0 to 3.5

The task result "Created distribution with assembly plugin." is not stated anywhere in the task requirements. Otherwise the analysis is good endough. Maybe it is a good idea to put the naming convention for the modules in some of the wiki pages (e.g. PLUGIN_MODULE_STRUCTURE) so that it is easily reachable. (30m)

comment:4 Changed 14 years ago by pav

  • Design_owners set to pav
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:5 Changed 14 years ago by pav

  • Status changed from s2a_design_started to s2b_design_finished


comment:6 Changed 14 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to pap

Nice but has some drawbacks:

  • Updates to the PLUGIN_MODULE_STRUCTURE wiki page are mandatory in my opinion. If you decide that there will be no time for the diagrams you should at least mention in the wiki page that they are outdated.
  • The "implementation of concrete base library" rule is not correct. It should be something like "Name the module like the implemented library but with main instead of base and a suffix that describes the implementation. (org.sophie2.base.lib_name -> org.sophie2.main.lib_name.impl_name)"

comment:7 Changed 13 years ago by deyan

  • Status changed from s2c_design_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.