Ticket #1779 (closed bug: worksforme)

Opened 10 years ago

Last modified 10 years ago

weird behavior when inserting book

Reported by: danvisel Owned by: danvisel
Priority: major Milestone: M09_BETA1
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: danvisel Design_owners:
Imp._owners: Test_owners:
Analysis_reviewers: Changelog:
Design_reviewers: Imp._reviewers:
Test_reviewers: Analysis_score: 0
Design_score: 0 Imp._score: 0
Test_score: 0

Description

  1. Open Sophie.
  2. Close default book (if there is one)
  3. Click on the Book Desktop to select it.
  4. Choose Insert > Text Frame and insert a text frame. Fill it with text.
  5. Choose Insert > Text Frame and insert a second text frame.
  6. Chain first text frame to second frame.
  7. Select and deselect the text frames & note how responsive Sophie is.
  8. Select a text frame; make sure that the chain HUD is open.
  9. Choose Insert > Book and select a previously saved Sophie book.
  10. Select and deselect the text frames & note how responsive Sophie is.

No book is inserted on step 10, but Sophie seems to slow down tremendously. It seems like this behavior only happens when the chain HUD is open and selected; otherwise the book imports normally. But it seems like something is going wrong here; the slowness continues until Sophie is restarted.

Change History

comment:1 Changed 10 years ago by danvisel

  • Owner set to danvisel
  • Status changed from new to s1a_analysis_started

comment:2 Changed 10 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:3 Changed 10 years ago by todor

sophie begins to slow down when inserting the second text frame even without the text and the embedding of the book, this happens only on mac

comment:4 Changed 10 years ago by deyan

  • Status changed from s1b_analysis_finished to closed
  • Total Hours set to 0
  • Add Hours to Ticket set to 0
  • Billable? set
  • Estimated Number of Hours set to 0
  • Resolution set to worksforme

this one seems fixed to me, can you retest it?

comment:5 Changed 10 years ago by danvisel

I think this particular problem is fixed. What I notice:

  • If I insert a new frame, dragging it takes very little time, less than 1 second.
  • If I fill that frame with text and drag it, that takes more time, about 5 seconds.
  • If I fill that frame with text, then chain it to another frame, then drag it, that also takes about 5 seconds.

So I don't think chaining is causing slowness - it's text that's causing the slowness.

Note: See TracTickets for help on using tickets.