Ticket #1867 (closed bug: fixed)

Opened 12 years ago

Last modified 11 years ago

UI: Bottom flap steals focus

Reported by: deyan Owned by: tanya
Priority: major Milestone: M11_BETA3
Component: uncategorized Version: 2.0
Keywords: Cc: tanya
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: tanya
Imp._owners: tanya Test_owners:
Analysis_reviewers: tanya Changelog:
Design_reviewers: -meddle Imp._reviewers: -meddle, pap, meddle
Test_reviewers: Analysis_score: 4
Design_score: 4 Imp._score: 3.5
Test_score: 0

Description

UI: Timelines flap often gets focus. This one is reported, but just found a way to reproduce it every time. Create 2-3 book and start scrolling between them clicking their title bars for example. No matter what was selected in the book, timeline flap always gets focus.

Change History

comment:1 Changed 12 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 12 years ago by tanya

  • Design_owners set to tanya
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to tanya

comment:3 Changed 12 years ago by tanya

comment:4 Changed 12 years ago by tanya

  • Status changed from s2a_design_started to s3b_implementation_finished

comment:5 Changed 12 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_reviewers set to tanya
  • Analysis_score changed from 0 to 4
  • Imp._reviewers set to meddle
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 4

Merged in [5209].

comment:6 Changed 12 years ago by tanya

  • Change the swingComponent() property in MDPalette class from auto property to resource property.
    • This should be done and will fix the problem because when the property is auto property new JComponent is created, the palette recreates every time and grabs the focus.

comment:7 Changed 11 years ago by tanya

  • Owner set to tanya

comment:8 Changed 11 years ago by tanya

  • Status changed from s3c_implementation_ok to s2c_design_ok

comment:9 Changed 11 years ago by tanya

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:10 Changed 11 years ago by tanya

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Design_reviewers changed from meddle to -meddle
  • Imp._reviewers changed from meddle to -meddle

The problem with the bottom flap is the swingComponent() property in ListPalette and in MDPalette. The swingComponent() property is AutoProperty but should be ResourceProperty. What is more, there are other classes with swingComponent() property and their swingComponent() property are also AutoProperties. These swingComponent() properties are changed to ResourceProperties because this is the correct way.

changeset [6148]

comment:11 Changed 11 years ago by pap

  • Summary changed from UI: Bottom flap streals focus to UI: Bottom flap steals focus

fixed a typo

comment:12 Changed 11 years ago by pap

  • Cc tanya added
  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._reviewers changed from -meddle to -meddle, pap, meddle
  • Ok although some of the changes to resource properties are a bit strange.

comment:13 Changed 11 years ago by pap

  • Imp._score changed from 4 to 3.5

adding score

comment:14 Changed 11 years ago by pap

integrated in [6163]

comment:15 Changed 11 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

fixed

Note: See TracTickets for help on using tickets.