Ticket #1878 (closed bug: later)

Opened 11 years ago

Last modified 10 years ago

Crash: HTML insert causes crash.

Reported by: todor Owned by: george
Priority: major Milestone: M11_BETA3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: george
Imp._owners: george Test_owners:
Analysis_reviewers: george Changelog:
Design_reviewers: meddle, todor Imp._reviewers: meddle, todor
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3
Test_score: 0

Description

Inserting html causes the application to crash.

Attachments

1878.txt (7.3 KB) - added by george 11 years ago.
Error log from the crash.

Change History

comment:1 Changed 11 years ago by todor

  • Status changed from new to s1b_analysis_finished

Changed 11 years ago by george

Error log from the crash.

comment:2 Changed 11 years ago by george

  • Design_owners set to george
  • Status changed from s1b_analysis_finished to s2a_design_started

comment:3 Changed 11 years ago by george

  • The crash in 1878.txt attached file is caused by an HTML meta tag that tries to change the encoding, not by the problem mentioned in the Description. The ChangedCharSetException in 1878.txt can be easily avoided by ignoring such tags.
  • The crash in the bug Description is caused by OutOfMemoryError: Java heap space.

comment:4 Changed 11 years ago by george

  • I tried to resize the memory of the JVM but the error still remains. For 5.7KB text file, 512mb maximum heap size is not enough. I think that the text layout is too heavy. The problem with large html files is the same - after all their content is imported as text in Sophie.
  • Solution:
  1. For the exception in the attached file (1878.txt): the line doc.putProperty("IgnoreCharsetDirective", new Boolean(true)); should be added in the HtmlImportManager#createRes() method.
  2. For the java heap space error: I hope that the new text layout will be better.

comment:5 Changed 11 years ago by george

  • Status changed from s2a_design_started to s2b_design_finished

comment:6 Changed 11 years ago by george

  • Status changed from s2b_design_finished to s2c_design_ok
  • Imp._owners set to george
  • Analysis_reviewers set to george

comment:7 Changed 11 years ago by george

  • Owner set to george
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:8 Changed 11 years ago by george

  • Status changed from s3a_implementation_started to s3b_implementation_finished

comment:9 Changed 11 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_score changed from 0 to 3
  • Imp._reviewers set to meddle, todor
  • Design_score changed from 0 to 3
  • Design_reviewers set to meddle, todor
  • Imp._score changed from 0 to 3

Merged in [5179].

comment:10 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to later
Note: See TracTickets for help on using tickets.