Ticket #1879 (closed bug: fixed)

Opened 12 years ago

Last modified 11 years ago

Crash: The 'Go to page...' and 'Go to next page' link actions cause an exception.

Reported by: deyan Owned by: nenko
Priority: major Milestone: M11_BETA3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: nenko
Imp._owners: nenko Test_owners:
Analysis_reviewers: nenko Changelog:
Design_reviewers: meddle, deyan Imp._reviewers: meddle, deyan
Test_reviewers: Analysis_score: 3.5
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

Links: The 'Go to page...' and 'Go to next page' link actions cause an exception.

Change History

comment:1 Changed 12 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 12 years ago by nenko

  • Design_owners set to nenko
  • Status changed from s1b_analysis_finished to s2a_design_started

comment:3 Changed 12 years ago by nenko

The exception thrown is fixed in 1906. However when GoToPage... link is triggered nothing happens so I will fix this one.

comment:4 Changed 12 years ago by nenko

  • Status changed from s2a_design_started to s2b_design_finished

The problem is that in preview mode the pages in the book are assumed to be the pages in the book minus one and this is wrong. Also GO_TO_PAGE logic is rewritten and now uses BookLogic#userJumpToPage instead of copy-pasting that code.

comment:5 Changed 12 years ago by nenko

  • Status changed from s2b_design_finished to s2c_design_ok

comment:6 Changed 12 years ago by nenko

  • Owner set to nenko
  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to nenko

comment:7 Changed 12 years ago by nenko

  • Status changed from s3a_implementation_started to s3b_implementation_finished

The fix is committed in 5237

comment:8 Changed 12 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_reviewers set to nenko
  • Analysis_score changed from 0 to 3.5
  • Imp._reviewers set to meddle, deyan
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle, deyan
  • Imp._score changed from 0 to 3.5

Merged into the release in [5242].

comment:9 Changed 11 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

fixed

Note: See TracTickets for help on using tickets.