Ticket #1943 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

Crash: When entering invalid data in the zoom field (e.g. text) and hit enter, an exception is thrown.

Reported by: boyan Owned by: boyan
Priority: critical Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: crash, zoom Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: boyan Design_owners: boyan
Imp._owners: boyan Test_owners: deyan
Analysis_reviewers: Changelog:
Design_reviewers: Imp._reviewers: pap
Test_reviewers: Analysis_score: 3
Design_score: 3 Imp._score: 3
Test_score: 3

Description

  1. Enter some text in the zoom percentage field in the book panel.
  2. Hit enter.

This leads to application crash.

Change History

comment:1 Changed 10 years ago by boyan

  • Status changed from new to s1b_analysis_finished

finishing bug report

comment:2 Changed 10 years ago by boyan

  • Status changed from s1b_analysis_finished to s2a_design_started

starting design

comment:3 Changed 10 years ago by boyan

  • Design_owners set to boyan
  • Status changed from s2a_design_started to s3b_implementation_finished
  • Imp._owners set to boyan
  • Analysis_owners set to boyan

The problem is in BoundComboBox:
Object input = res.getSelectedItem(); might return String if text is entered and no item is selected. We should not submit the data in this case. This is easily solved by an additional check: [6123].

comment:4 Changed 10 years ago by pap

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 0 to 1
  • Imp._reviewers set to pap

This solution is incorrect as we may desire that the input of some concrete control is of type String.

comment:5 Changed 10 years ago by boyan

  • Status changed from s2c_design_ok to s3a_implementation_started

started reimplementation

comment:6 Changed 10 years ago by boyan

  • Status changed from s3a_implementation_started to s3b_implementation_finished

reimplemented: [6159]. This is not a good fix but a fundamental refactoring of all bound controls is requred for a better one.

comment:7 Changed 10 years ago by pap

  • Cc boyan added
  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 1 to 3

I find this more like a workaround but it is acceptable

comment:8 Changed 10 years ago by boyan

  • Cc boyan removed

removing cc

comment:9 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Analysis_score changed from 0 to 3
  • Test_score changed from 0 to 3
  • Test_owners set to deyan
  • Design_score changed from 0 to 3
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.