Ticket #2032 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

[natives] HTML export: extension is not added to the filename; improper overwriting

Reported by: deyan Owned by:
Priority: major Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: nenko
Imp._owners: nenko Test_owners:
Analysis_reviewers: nenko Changelog:
Design_reviewers: deyan Imp._reviewers: deyan
Test_reviewers: deyan Analysis_score: 3
Design_score: 4 Imp._score: 4
Test_score: 4

Description (last modified by deyan) (diff)

  • When you export a book into HTML the ".htm" extension is not added automatically to the filename but it should.
  • When you export a book over existing html, a dialog asking if you want to overwrite the existing html should appear but it doesn't (see #2030)

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished
  • Description modified (diff)

comment:2 Changed 10 years ago by nenko

  • Design_owners set to nenko
  • Status changed from s1b_analysis_finished to s2a_design_started

comment:3 Changed 10 years ago by nenko

  • Status changed from s2a_design_started to s3b_implementation_finished
  • Imp._owners set to nenko

This bug is fixed in svn://sophie2.org/sophie2/branches/private/nenko/natives2 in changesets:
[6850]
[6869]

However I couldn't reproduce the "extension not added problem". The extension that is automatically added is html...

comment:4 Changed 10 years ago by deyan

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Test_reviewers set to deyan
  • Analysis_reviewers set to nenko
  • Analysis_score changed from 0 to 3
  • Imp._reviewers set to deyan
  • Design_score changed from 0 to 4
  • Design_reviewers set to deyan
  • Imp._score changed from 0 to 4

comment:5 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to fixed

comment:6 Changed 10 years ago by deyan

  • Test_score changed from 0 to 4
Note: See TracTickets for help on using tickets.