Ticket #2106 (closed bug: fixed)

Opened 11 years ago

Last modified 11 years ago

GradientHud does not appear and Sophie crashes because of a missing image.

Reported by: peko Owned by: pap
Priority: critical Milestone: M12_RELEASE
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: Design_owners: pap, tsachev
Imp._owners: pap Test_owners: vanya
Analysis_reviewers: pap Changelog:
Design_reviewers: meddle Imp._reviewers: meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 4 Imp._score: 4
Test_score: 0

Description

Steps to reproduce the bug:

  • Start Sophie2.
  • Create a new book.
  • Click on the appearance hud button(the first button in the halo menu positioned at the top left corner of the page).
  • In the background section of the hud that appears select the gradient background type from the drop down menu.
  • Click on the button at the right of the drop down menu to customize the gradient form the gradient hud.

> Exception is thrown and Sophie2 stops responding.

Change History

comment:1 Changed 11 years ago by peko

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 11 years ago by pap

  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to pap
  • Analysis_score changed from 0 to 3.5
  • accepted

comment:3 Changed 11 years ago by pap

  • Design_owners set to pap, tsachev
  • Owner set to pap
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:4 Changed 11 years ago by pap

  • Status changed from s2a_design_started to s2b_design_finished
  • The problem is in the Synth LaF not finding an icon used in BoundSpinner.
  • The missing icon was HScrollBar/thumb_disabled.png
  • Temporary fix in [7605] (in trunk). The missing icon is used in many places so we just put a rotated version of the VScrollBar/thumb_disabled.png
  • Now the spinner is drawn but its arrows are transparent
  • For a proper fix we need a new asset and a new section in the LaF xml files.

comment:5 Changed 11 years ago by pap

comment:6 Changed 11 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok

comment:7 Changed 11 years ago by pap

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:8 Changed 11 years ago by pap

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Imp._owners set to pap
  • Actually the second commit fixed the transparency problem so I consider the bug fixed, although the spinner and arrows may still need styles in the LaF xml.

comment:9 Changed 11 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to meddle

Ya, I think it's working...

4p

comment:10 Changed 11 years ago by vanya

  • Status changed from s3c_implementation_ok to closed
  • Test_owners set to vanya
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.