Ticket #2245 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

media-not-smooth -- When you play an audio, the timeline stops every 10 sec.

Reported by: deyan Owned by: meddle
Priority: blocker Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 99 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: meddle
Imp._owners: meddle, milo Test_owners:
Analysis_reviewers: meddle Changelog:
Design_reviewers: pap Imp._reviewers: pap
Test_reviewers: Analysis_score: 3
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

When you play audio or video, the timeline stops every 10 seconds. If you use background audio and play the timeline twice, on the second time first 12 seconds are not heard.

Change History

comment:1 Changed 10 years ago by meddle

  • Design_owners set to meddle
  • Status changed from new to s1c_analysis_ok
  • Analysis_reviewers set to meddle
  • Analysis_score changed from 0 to 3

The problem is only with some formats... like mp3

comment:2 Changed 10 years ago by meddle

  • Owner set to meddle
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:3 Changed 10 years ago by meddle

  • Status changed from s2a_design_started to s2b_design_finished
  • The problems:
    • Some of the media formats have bad packets in the beginning (for example mp3s and movs) and a runtime_exception is thrown in the native code, so when the buffer is been filled, the operation is restarted as many times as the number of these packets is.
    • The audio is bad when fulling the big buffer (10000ms)
    • You can not insert video files as audio frames in sophie. The problem is that these files are not count as media files from the FileDialog so they don't have an ImportBinDataType.
  • The solutions:
    • Catch try-catch the exception when calling the decodeAudio function and continue with the next packet instead. The problem is solved.
    • Also the audio quality is better when the buffer is 1000+200, there is no bad audio anymore, and the most of the videos play better.
    • Let the media files that are playable, but are not in the list of the file types in the FileDialog have ImportBinDataType.LINKED by default.
  • Found problems for fixing:
    • Some video formats have problems with the audio when the buffer extra is under 1200-1300 ms must be added as a bug.

comment:4 Changed 10 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Imp._owners set to meddle, milo

comment:5 Changed 10 years ago by meddle

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:6 Changed 10 years ago by meddle

  • Status changed from s3a_implementation_started to s3b_implementation_finished

The implementation is on pap's machine so when he review it he can commit it :)

comment:7 Changed 10 years ago by pap

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to pap
  • Imp._score changed from 0 to 3.5
  • Imp._reviewers set to pap
  • Seems acceptable.
  • It would be better if you had written that the decodeAudio function is in media_decoder.h or the exact class :)
  • Commited to trunk in [8470] and [8479].

comment:8 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.