Ticket #2250 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

fast-text-changes -- Text changes are saved only when you type slow

Reported by: deyan Owned by: mira
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 89 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: mira
Imp._owners: mira Test_owners:
Analysis_reviewers: mira Changelog:
Design_reviewers: meddle Imp._reviewers: meddle, todor
Test_reviewers: Analysis_score: 3
Design_score: 3.5 Imp._score: 3
Test_score: 0

Description

Insert a text frame, type in some text fast. Try to undo - nothing happens. Undo some more times, the "insert frame" is undone, but the "set text" isn't.

Attachments

revert_last_unsign_changes.patch (2.0 KB) - added by mira 10 years ago.
change-set

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by deyan

  • Importance set to 89

comment:3 Changed 10 years ago by mira

  • Design_owners set to mira
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Analysis_score changed from 0 to 3

comment:4 Changed 10 years ago by mira

  • Status changed from s2a_design_started to s2b_design_finished

The problem is that there are some insignificant text changes that are not closed by a significant one. The algorithm of finding a change to redo should check for unclosed changes and acts as if the last unsignificant change was significant. This way the undo will always revert the effect of the last changes made from this view. However, the problem with other significant changes interfiering still remains. This means that if you type fast and then rotate the frame, this will become the enclosing change of all unclosed set text changes.

comment:5 Changed 10 years ago by mira

  • Status changed from s2b_design_finished to s2c_design_ok

comment:6 Changed 10 years ago by mira

  • Owner set to mira
  • Status changed from s2c_design_ok to s3a_implementation_started

comment:7 Changed 10 years ago by mira

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Only one method was changed. There is a patch file attached to this ticket.

comment:8 Changed 10 years ago by mira

  • Imp._owners set to mira
  • Analysis_reviewers set to mira

Changed 10 years ago by mira

change-set

comment:9 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3
  • Imp._reviewers set to meddle, todor
  • Undo of backspace is not behaving as expected.
  • No matter how fast you write when you undo the first letter stays most of the times.
  • Undo of writing removes random number words (sometimes undo removes letters sometimes several words).
  • Select text and delete it, try to undo it.
  • Redo doesn't work sometimes, often.
  • Undo of styles doesn't work.
  • The right behavior is the one used by word and many other text editors.
  • When user presses on Ctrl+Z the whole word must be removed, if the user however makes changes to some word Ctrl+Z removes only the new changes (see ms word).

3p but passes...

comment:10 Changed 10 years ago by meddle

Merged to the trunk at [8567].

comment:11 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.