Ticket #2260 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

stickies-throw-an-exception-on-copy-paste - When trying to copy something from sticky or paste something in it, exception is thrown.

Reported by: todor Owned by:
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 88 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: deni Changelog:
Design_reviewers: meddle Imp._reviewers: meddl
Test_reviewers: Analysis_score: 3
Design_score: 4 Imp._score: 4
Test_score: 0

Description

  • Create sticky.
  • Write some text in it.
  • Copy text from the sticky or try to paste something in the sticky.
  • Exception is thrown.

The proper behavior is to copy/paste text and nothing to happen when trying to paste resource different from text.

Attachments

copy-paste-text-in-stickies.patch (9.8 KB) - added by deni 10 years ago.

Change History

comment:1 Changed 10 years ago by todor

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by deni

  • Status changed from s1b_analysis_finished to s2a_design_started

comment:3 Changed 10 years ago by deni

  • Design_owners set to deni
  • Status changed from s2a_design_started to s3b_implementation_finished
  • Imp._owners set to deni
  • Analysis_reviewers set to deni
  • Analysis_score changed from 0 to 5
  • Copy/paste text in stickies:
    • TextFrameLogic's ON_COPY, ON_CUT and ON_PASTE operations:
      • Generally they are responsible for converting SophieDragDropHandler.TransferEventIds.COPY events related to text to TextView.EventIds.COPY events.
      • They should do it for all TextElements, not only TextFrameViews.
        • Since TextElement is an interface and does not extends ElementView, we cannot make such a call: AppHaloUtil.getSingleSelected(source, TextElement.class).
        • Therefore we should get the single selected ElementView and manually check whether it is TextElement.
    • Move the above operations in HotTextLogic, since they are no longer so closely related to TextFrameViews.
    • Rename them to avoid naming conflicts and to emphasize that they are related to cut/copy/paste from the menu.
    • Pasting styled text from text frames to stickies will keep the formatting... This is not very consistent, because when typing text in stickies the users don't have the controls to format their text, but I'm leaving it this way.
  • Paste other resources:
    • Currently if you have copied an image frame, for example, and you are typing in a text frame, Ctrl+V will paste the image frame in the current group or page. The expected behavior is that nothing happens.
    • In the ON_PASTE operation if the selected view is a TextElement, return that the event was handled, no matter whether some text was actually inserted or not.

Changed 10 years ago by deni

comment:4 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_score changed from 5 to 3
  • Imp._reviewers set to meddl
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 4

In the trunk since [8496]...

The names of the handlers are a bit strange, because ctrl+C is also handled by them, but I can not think of better ones myself...

And why the hell the analysis is 5, five is something god-like

comment:5 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.