Ticket #2269 (closed bug: obsolete)

Opened 9 years ago

Last modified 8 years ago

overwrite-text-from-beginning -- When you overwrite text from beginning, styling is lost

Reported by: deyan Owned by:
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 80 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deyan Design_owners: diana
Imp._owners: diana Test_owners:
Analysis_reviewers: diana Changelog:
Design_reviewers: meddle, kyli Imp._reviewers: meddle, kyli, deyan, todor
Test_reviewers: Analysis_score: 3
Design_score: 4 Imp._score: 3
Test_score: 0

Description

Create a text frame, type in some paragraphs with styling. When you select from the beginning of the paragraph and overwrite, the styling is lost (it should be like it was on first position). If you select and delete, then type - the styling should be lost.

Attachments

2269.patch (25.8 KB) - added by diana 9 years ago.

Change History

comment:1 Changed 9 years ago by deyan

  • Status changed from new to s1b_analysis_finished
  • Milestone set to X3

comment:2 Changed 9 years ago by diana

  • Design_owners set to diana
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to diana

comment:3 Changed 9 years ago by diana

  • Status changed from s2a_design_started to s3b_implementation_finished
  • In ImmHotText:replace get the style of the first letter of the selected text to be replaced and apply the style to the text to replace in rder to be consistent.

Changed 9 years ago by diana

comment:4 Changed 9 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_reviewers set to diana
  • Analysis_score changed from 0 to 3
  • Imp._reviewers set to meddle, kyli, deyan, todor
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle, kyli
  • Imp._score changed from 0 to 3

Merged to the trunk at [8599].

Hard to read code, but the problem is mainly in the current text state.

  • Bad expressions, too long and unreadable with bad hyphenation and bed spacing.
  • Strange and meaningless variable names.

Analysis review?!

3p

comment:5 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.