Ticket #2279 (closed bug: obsolete)

Opened 10 years ago

Last modified 8 years ago

activation-channel-object-names -- Objects in the timeline palette are named "New Resource" instead of actual names

Reported by: deyan Owned by:
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: tsachev Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: deni Changelog:
Design_reviewers: meddle Imp._reviewers: meddle, deyan
Test_reviewers: Analysis_score: 4
Design_score: 4 Imp._score: 4
Test_score: 0

Description

In timelines palette when you have focused the page, activation channels are named "Activation for New Resource". They should contain the actual resource names

Attachments

activation-channel-object-names.patch (1.6 KB) - added by deni 10 years ago.

Change History

comment:1 Changed 10 years ago by deni

  • Category set to unknown
  • Status changed from new to s1b_analysis_finished
  • Analysis_score set to 0
  • Test_score set to 0
  • Design_score set to 0
  • Imp._score set to 0

comment:2 Changed 10 years ago by deni

  • Design_owners set to deni
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to deni
  • Analysis_reviewers set to deni
  • Analysis_score changed from 0 to 4

comment:3 Changed 10 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished
  • The problem is in TimelinesPalette.namesPanel().namesPanel.getChannelLabel(Channel<?, ?>)
  • ActivationChannel.getElementResource() returns a relative reference from the parent to the child that is controlled by the channel. We cannot use this reference to open an access from the book to the element. However, we can use it to open an access from the parent to the child. We can get an access to the parent from the elementView() property.

Changed 10 years ago by deni

comment:4 Changed 9 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 4
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to meddle, deyan

Merged to the trunk at [8609].

4p

comment:5 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.