Ticket #2338 (closed bug: obsolete)

Opened 10 years ago

Last modified 9 years ago

bug-report-explanation - - In bug report form the dialog is inaccurate

Reported by: deyan Owned by: pap
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: 95 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: deni, deyan Design_owners: pap
Imp._owners: pap Test_owners:
Analysis_reviewers: pap Changelog: Changelog
Design_reviewers: kyli Imp._reviewers: kyli
Test_reviewers: Analysis_score: 4
Design_score: 4 Imp._score: 4
Test_score: 0

Description

In bug report form user explanation is mandatory (which is okay), but the dialog says "Valid e-mail address is mandatory"

  • Create a new dialog saying "User explanation field should not be blank". The dialog should be shown when the field is left blank

Attachments

bugReport.patch (1.9 KB) - added by pap 10 years ago.

Change History

comment:1 Changed 10 years ago by deyan

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by pap

  • Design_owners set to pap
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to pap
  • Taking for design

comment:3 Changed 10 years ago by pap

  • Status changed from s2a_design_started to s2b_design_finished
  • The problem is in BugReportLogic.ON_SEND_REPORT.handle.
  • Add separate messages for missing e-mail and user explanation

comment:4 Changed 10 years ago by pap

  • Status changed from s2b_design_finished to s2c_design_ok
  • Continuing

comment:5 Changed 10 years ago by pap

  • Owner set to pap
  • Status changed from s2c_design_ok to s3a_implementation_started
  • Starting implementation

Changed 10 years ago by pap

comment:6 Changed 10 years ago by pap

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Implementation is in the attached patch. It is relative to the BugReportLogic.java file in the org.sophie2.main.func.help module

comment:7 Changed 10 years ago by pap

  • Analysis_reviewers set to pap
  • Analysis_score changed from 0 to 4

comment:8 Changed 10 years ago by kyli

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 4
  • Design_reviewers set to kyli
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to kyli
  • The bug report form has some interesting problems related to the field validation. Please, investigate them some day :)
  • You have mistaken the string for the error message :D

4p. Merged with trunk at [8700].

comment:9 Changed 9 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.