Ticket #2427 (closed bug: obsolete)

Opened 9 years ago

Last modified 8 years ago

deleting-media-frame-throws-an-exception - When you try to delete media frame, exception occurs.

Reported by: todor Owned by: meddle
Priority: major Milestone: X3
Component: uncategorized Version: 2.0
Keywords: Cc: meddle
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: todor Design_owners: meddle
Imp._owners: meddle Test_owners:
Analysis_reviewers: meddle Changelog: Changelog
Design_reviewers: pap Imp._reviewers: deyan, todor, pap
Test_reviewers: Analysis_score: 4
Design_score: 4 Imp._score: 4
Test_score: 0

Description (last modified by deyan) (diff)

Attachments

2427.patch (861 bytes) - added by meddle 9 years ago.
Patch
autoActions.patch (46.3 KB) - added by meddle 9 years ago.
Auto actions and fixes
actions2.patch (134.1 KB) - added by meddle 9 years ago.
Second patch
2427_all_in_one.patch (64.4 KB) - added by meddle 9 years ago.
All in one patch

Change History

comment:1 Changed 9 years ago by todor

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 9 years ago by meddle

  • Status changed from s1b_analysis_finished to new
  • Analysis_reviewers set to meddle
  • Analysis_score changed from 0 to 2
  • The ticket does not point the actual exception!

2p

comment:3 Changed 9 years ago by deyan

  • Status changed from new to s1b_analysis_finished
  • Description modified (diff)

comment:4 Changed 9 years ago by meddle

  • Cc meddle added
  • Design_owners set to meddle
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Analysis_score changed from 2 to 4

OK, now it makes sense, the exception is in my area :)

Changed 9 years ago by meddle

Patch

comment:5 Changed 9 years ago by meddle

  • Status changed from s2a_design_started to s2b_design_finished

The problem is strange...

  • First of all it happened only when Sophie war running under Windows.
  • The reason is that the timer runs a task that became null for some reason.
    • That I fixed with passing to the timer other reference to a task, different from the field in the view that in some circumstances is set to null.
    • The attached patch contains that fix, it is tested under Windows.

comment:6 Changed 9 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok

comment:7 Changed 9 years ago by meddle

  • Owner set to meddle
  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to meddle

comment:8 Changed 9 years ago by meddle

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Implementation

  • All the tests in the main.func.resources module are fixed to run.
  • All the auto actions in the main.func.resources are converted to top level classes.
  • The problem with the windows file separators is solved.

Changed 9 years ago by meddle

Auto actions and fixes

comment:9 Changed 9 years ago by meddle

The two patches should be applied one after another.

Changed 9 years ago by meddle

Second patch

comment:10 Changed 9 years ago by meddle

The second patch replaces the autoActions.patch. This should fix #2407

Changed 9 years ago by meddle

All in one patch

comment:11 Changed 9 years ago by meddle

The last patch has all the open problems found by deyan and todor fixed and all the non-testing Annotation related AutoActions pulled out to top classes.

  • Windows books with linked resources don't lose them under linux.
  • There is no exceptions while deleting frames.
  • DND under windows works in server books (see #2407).
  • More than 10 AutoActions moved.

comment:12 Changed 9 years ago by pap

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Design_score changed from 0 to 4
  • Design_reviewers set to pap
  • Imp._score changed from 0 to 4
  • Imp._reviewers set to deyan, todor, pap

comment:13 Changed 8 years ago by meddle

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Closing all the tickets before M Y1

Note: See TracTickets for help on using tickets.