Ticket #2439 (closed bug: obsolete)
skinning-improvement
Reported by: | tanya | Owned by: | |
---|---|---|---|
Priority: | major | Milestone: | |
Component: | uncategorized | Version: | 2.0 |
Keywords: | Cc: | ||
Category: | unknown | Effort: | |
Importance: | Ticket_group: | ||
Estimated Number of Hours: | 0 | Add Hours to Ticket: | 0 |
Billable?: | yes | Total Hours: | 0 |
Analysis_owners: | tanya | Design_owners: | tanya |
Imp._owners: | tanya | Test_owners: | |
Analysis_reviewers: | Changelog: | Changelog | |
Design_reviewers: | pap | Imp._reviewers: | deyan, pap |
Test_reviewers: | Analysis_score: | 0 | |
Design_score: | 3.5 | Imp._score: | 3.5 |
Test_score: | 0 |
Description
Skinning should be improved according to the following comments
2411#comment:17
Attachments
Change History
comment:2 Changed 15 years ago by tanya
- Status changed from s1b_analysis_finished to s2a_design_started
comment:3 Changed 15 years ago by tanya
- LanguageSkin file is removed.
- Commented code from the Skin class removed.
- Loglevel in SkinManager changed to trace.
- getValue and getValues are made protected
- SkinEntry renamed to SkinValueLoader. Javadoc fixed.
- TextSkinEntry renamed to TextValueLoader. Javadoc fixed.
- SkinsNames class deleted. The constants moved to SkinManager. The value of LANGUAGE_PACK_NAME changed from language:en to language:default.
- getContent renamed to loadPart, loadBaseSkinParts renamed to loadSkinParts. getContent was fiex as it was suggested.
- language skin renamed to language pack everywhere
- createSkin method made private
- New packages created - org.sophie2.base.skins.providers, org.sophie2.base.skins.value.loaders
- the visibility of the fallback() property changed from package visible to public
- the visibility of the name() property changed from public to private
- createSkin method changed to take one more parameter - packName.
- Javadoc of the SkinPartsProvider fixed.
- Kind is not referred as "type" any more.
- searchSkin fixed. getValue method of the Skin class search in the fallback skin, after that searchSkin search in the fallback skin. so searching in the fallback skin in the searchSkin method is removed. searchSkin is made private.
- assert in createValue changed. it is only one statement now and message is added.
- initRecord method of SkinManager fixed. If the line could not be split on 3 parts, an error message will appear and the line will be skipped. If the line can be split on more that 3 parts, the line will be split on only 3.
- in skinCache the names of the skins will be in lower case. put and get methods predefined. for skin with name "none", null value is put in the map.
- createSkin method changed. getFallbackSkinName method created.
comment:4 Changed 15 years ago by tanya
- Status changed from s2a_design_started to s3b_implementation_finished
comment:6 Changed 15 years ago by pap
- Status changed from s3b_implementation_finished to s3c_implementation_ok
- Design_score changed from 0 to 3.5
- Design_reviewers set to pap
- Imp._score changed from 0 to 3.5
- Imp._reviewers set to deyan, pap
- Commited in [9178]
- You forgot to rename the method in {{{BaseSkinsModule}} that gets the SkinValueLoader extension point.
- SkinUtil.getSkinValue needs its logic improved when you implement the next task. I hope you see the duplicated code.
- SkinUtil.getSkinValues is inconsistent as it looks only in the current skin and knows nothing about language and other packs.
- The JavaDoc of SkinPartsProvider is incorrect. It is NOT an extension point itself.
- Same for SkinValueLoader
- I think that in SkinManager.createSkin if you can't find the skinDef you should return the None value.
- Not even a single custom field for an owner or reviewer was filled in
Note: See
TracTickets for help on using
tickets.