Ticket #1350 (closed planned_task: obsolete)

Opened 11 years ago

Last modified 10 years ago

AUTHOR_APP_TUNING_R3

Reported by: Astea Owned by: peko
Priority: 3 Milestone: M07_ALPHA2
Component: SOPHIE_END_PRODUCT Version: 2.0
Keywords: Cc: dido, peko
Category: END_PROD Effort: 1
Importance: 0 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: peko Design_owners: peko, dido
Imp._owners: peko Test_owners:
Analysis_reviewers: dido Changelog:
Design_reviewers: meddle Imp._reviewers: meddle, todor, meddle, todor
Test_reviewers: Analysis_score: 4
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

wiki page: AUTHOR_APP_TUNING_R3 - effort: 1d

Change History

comment:1 Changed 10 years ago by peko

  • Status changed from new to s1a_analysis_started
  • Total Hours set to 0
  • Analysis_score set to 0
  • Test_score set to 0
  • Add Hours to Ticket set to 0
  • Design_score set to 0
  • Billable? set
  • Owner changed from Astea to peko
  • Estimated Number of Hours set to 0
  • Imp._score set to 0
  • Analysis_owners set to peko

comment:2 Changed 10 years ago by peko

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:3 Changed 10 years ago by dido

  • Cc dido, peko added
  • Status changed from s1b_analysis_finished to s1c_analysis_ok
  • Analysis_reviewers set to dido
  • Analysis_score changed from 0 to 4

Analysis reviewed 4p (10m)

comment:4 Changed 10 years ago by peko

  • Design_owners set to peko, dido
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:5 Changed 10 years ago by peko

  • Status changed from s2a_design_started to s2b_design_finished

comment:6 Changed 10 years ago by meddle

  • Status changed from s2b_design_finished to s2c_design_ok
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle

The design is good :)

  • The repeating code in TilePainter.java is bad thing.
  • And the fact that the xml is moved out of the distrib directory is minus too, but if at the moment is impossible otherwise, so be it...

3.5p (50m)

comment:7 Changed 10 years ago by peko

  • Status changed from s2c_design_ok to s3a_implementation_started
  • Imp._owners set to peko

comment:8 Changed 10 years ago by peko

  • Status changed from s3a_implementation_started to s3b_implementation_finished
  • Fixed the tile painter.
  • Fixed the tab tab. Its height is moved to the skin.

comment:9 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s2c_design_ok
  • Imp._score changed from 0 to 2
  • Imp._reviewers set to meddle, todor

Problems:

  • There are issues with default skin bound controls icons. The buttons in the book titlebar for next/prev page and for search.
  • When changing between skins the flap position must be preserved.
  • When choosing maximize the window is not maximized properly because of its shadow.
  • When switching between skins the page desktop constantly expands.
  • When resizing flap and then minimizing it we have the bug that is visible in the attachment in the wiki page. (Hard to reproduce, but ugly :))

2p (90m)

comment:10 Changed 10 years ago by dido

there are 2 ways to proceed

  • The first one is fix this issues in this task
  • The second is to include them in the next revision

Also there are a lot of issues related to the documents tab bar, documents window, flaps, huds and so on.
My opinion is that fixing this specific issues in this revision gives them higher priority than they deserve.
However I agree that the following issues should be fixed before integrating this in the application.

  • When changing between skins the flap position must be preserved.
  • When switching between skins the page desktop constantly expands.
  • When resizing flap and then minimizing it we have the bug that is visible in the attachment in the wiki page. (Hard to reproduce, but ugly :))

It seems to me that the 2 other issues are little more complex than explained.

  • There are issues with default skin bound controls icons. The buttons in the book titlebar for next/prev page and for search. - Book view options panel is far far away from the desired state. Instead of fixing little part my proposal is to push this to final stage and finish with this once and for all. (It's not nice that the functionality in the old skin suffers from this)
  • When choosing maximize the window is not maximized properly because of its shadow. - Again the look and feel for documents window is not finished. The margins are not correct, the shadow doesn't draw itself correctly (not so hard to reproduce) etc.

Should we fix the last two issues in this revision or leave them for the next one?
Please share your thoughts on this.

comment:11 Changed 10 years ago by peko

  • Status changed from s2c_design_ok to s3a_implementation_started
  • There are issues with default skin bound controls icons. The buttons in the book titlebar for next/prev page and for search. - fixed. Now buttons have different icons for every state.
  • When changing between skins the flap position must be preserved. - this is not possible, since look and feel updating of mydoggy is not something we can control.
  • When choosing maximize the window is not maximized properly because of its shadow. - decided to leave the shadow for the time being. Otherwise the book window will be left with an ugly border.
  • When switching between skins the page desktop constantly expands. - fixed.
  • When resizing flap and then minimizing it we have the bug that is visible in the attachment in the wiki page. (Hard to reproduce, but ugly :))... This is something that appeared only once on my machine and I cannot understand why, because it happens rarely and there is little success in finding the reason. This will be fixed in the next revision.

comment:12 Changed 10 years ago by peko

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Added new tabs for the layout. These are exactly the tabs that are provided by shift. There are still issues with making mydoggy look exactly as proposed by shift.

comment:13 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._score changed from 2 to 3.5
  • Imp._reviewers changed from meddle, todor to meddle, todor, meddle, todor

OK but the bug with the reader in full screen and the right border must be fixed and in the next revision the default skin must be the new one.

3.5p (40m)

comment:14 Changed 10 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Resolution set to obsolete

Batch update from file query-obsoleted.csv

Note: See TracTickets for help on using tickets.