Ticket #1750 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

crash on previewing links

Reported by: danvisel Owned by: deni
Priority: critical Milestone: M09_BETA1
Component: uncategorized Version: 2.0
Keywords: Cc:
Category: unknown Effort:
Importance: Ticket_group:
Estimated Number of Hours: Add Hours to Ticket:
Billable?: Total Hours:
Analysis_owners: danvisel Design_owners: deni
Imp._owners: deni Test_owners:
Analysis_reviewers: Changelog:
Design_reviewers: mira Imp._reviewers: mira
Test_reviewers: dido Analysis_score: 0
Design_score: 3 Imp._score: 3
Test_score: 0

Description

Made a book of page 5 of the demo script. On clicking the Preview button (step 45), a crash happens, attached.

This doesn't happen if the book is saved before previewing, but then the links seem to be lost.

(This might be related to http://sophie2.org/trac/ticket/1710 but the bug report seems different.)

Attachments

crash on previewing links.txt.zip (34.3 KB) - added by danvisel 10 years ago.
crash on previewing links; zipped because of size.
demo page 5v2.sjrb (40.8 KB) - added by danvisel 10 years ago.
demo book for replicating error

Change History

Changed 10 years ago by danvisel

crash on previewing links; zipped because of size.

Changed 10 years ago by danvisel

demo book for replicating error

comment:1 Changed 10 years ago by danvisel

  • Owner set to danvisel
  • Status changed from new to s1a_analysis_started

Easy way to replicate this: open "demo page 5v2.sjrb", select the "close" button, open the link HUD, add a link, make it hide frame 4. Then click "Preview": you get this crash.

comment:2 Changed 10 years ago by danvisel

  • Status changed from s1a_analysis_started to s1b_analysis_finished

comment:3 Changed 10 years ago by deni

  • Status changed from s1b_analysis_finished to s1c_analysis_ok

comment:4 Changed 10 years ago by deni

  • Owner changed from danvisel to deni
  • Status changed from s1c_analysis_ok to s2a_design_started

comment:5 Changed 10 years ago by deni

  • Status changed from s2a_design_started to s2b_design_finished
  • The problem is that Link, LinkAction and all their subclasses don't follow the convention that every ProObject should have a constructor with a single ChangeManager argument.
  • The necessary constructors will be added.
  • LinkActionProvider's create method will have a ChangeManager parameter - the change manager responsible for the ActionLink-s the provider creates.
  • In LinksHud when we create a new LinkAction, it should have an appropriate change manager - that of the hud's holder (frame or page)
  • In Frame.link().compute() the new FrameLink should be created with the changeManager of the frame. The same applies for Page.link().compute().

comment:6 Changed 10 years ago by deni

  • Status changed from s2b_design_finished to s2c_design_ok

comment:7 Changed 10 years ago by deni

  • Status changed from s2c_design_ok to s3a_implementation_started

comment:8 Changed 10 years ago by deni

  • Status changed from s3a_implementation_started to s3b_implementation_finished

Changeset: [3916]

comment:9 Changed 10 years ago by mira

  • Design_owners set to deni
  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Imp._owners set to deni
  • Imp._reviewers set to mira
  • Design_score changed from 0 to 3
  • Design_reviewers set to mira
  • Imp._score changed from 0 to 3

Integrated in [3928] along with #1731, #1706.

comment:10 Changed 10 years ago by dido

  • Status changed from s3c_implementation_ok to closed
  • Test_reviewers set to dido
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.