Ticket #2203 (closed bug: fixed)

Opened 10 years ago

Last modified 9 years ago

ADDITIONAL_ELEMENTS_INSIDE_LINKS_HUD

Reported by: dido Owned by:
Priority: major Milestone: X3
Component: LINKS Version: 2.0
Keywords: Cc:
Category: END_PROD Effort:
Importance: 70 Ticket_group:
Estimated Number of Hours: 0 Add Hours to Ticket: 0
Billable?: yes Total Hours: 0
Analysis_owners: dido Design_owners: deni
Imp._owners: deni Test_owners: deyan
Analysis_reviewers: deni Changelog:
Design_reviewers: meddle Imp._reviewers: todor, meddle
Test_reviewers: Analysis_score: 3.5
Design_score: 3.5 Imp._score: 3.5
Test_score: 0

Description

  1. Insert frame, and select it.
  2. Open the link hud and create link that has "show frame" action. The combo box appear in order to choose specific frame.
  3. Don't close the hud and select the page - Links hud for the page is opened have no rule, but the "Select frame" combo box is visible and enabled.

The expected behavior is that there shouldn't be additional controls inside the hud if no specific action is selected.

Attachments

linkshud.patch (2.5 KB) - added by deni 10 years ago.

Change History

comment:1 Changed 10 years ago by dido

  • Status changed from new to s1b_analysis_finished

comment:2 Changed 10 years ago by milo

  • Importance set to 70

comment:3 Changed 10 years ago by deni

  • Design_owners set to deni
  • Status changed from s1b_analysis_finished to s2a_design_started
  • Imp._owners set to deni
  • Analysis_reviewers set to deni

Changed 10 years ago by deni

comment:4 Changed 10 years ago by deni

  • Status changed from s2a_design_started to s3b_implementation_finished
  • The problem was in LinksHud.ConfigPanel.swingComponent().swingComponent.setup(JPanel) - if no appropriate configuration panel is found, we didn't remove the previous one.
  • Fixed in the attched patch.
  • Besides, in the patch I changed the order of Send and Cancel buttons in bug report form dialog, so that Cancel is the rightmost button.

comment:5 Changed 10 years ago by meddle

  • Status changed from s3b_implementation_finished to s3c_implementation_ok
  • Analysis_score changed from 0 to 3.5
  • Imp._reviewers set to todor, meddle
  • Design_score changed from 0 to 3.5
  • Design_reviewers set to meddle
  • Imp._score changed from 0 to 3.5
  • Analysis_owners set to dido

Merged to the trunk at 8305...

3.5p

comment:6 Changed 9 years ago by deyan

  • Status changed from s3c_implementation_ok to closed
  • Test_owners set to deyan
  • Resolution set to fixed

fixed

Note: See TracTickets for help on using tickets.